
  

 

 

 

INTRODUCTION 
 

“Ucancam User Manual” was written specially for users of Ucancam engraving software. The 

content in this manual includes installation of the software, editing of text and drawings, object 

operation, creation and simulation of tool paths, etc. 

For the latest information about Ucancam, please visit our website www.ucancam.com. 
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 “Ucancam User Manual” is provided for users of Ucancam and gives a detailed instruction 

about installation and operations of Ucancam.  

Ucancam has powerful functions and convenient interfaces. It has been widely used in such 

fields as advertisements, mould-making, sign-making, gift-manufacturing, decoration, art works, 

woodworking, etc. 

There are twelve chapters in this manual, including Ucancam installation, basic operations, 

shape drawing, object operations, shape editing, text editing, node editing, tool paths, etc. 
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1. SYSTEM REQUIREMENTS & INSTALLATION 
 

1.1 System Requirements  

 CPU: P4 2.4G or above, or same-level CPU, (preferable Dual-Core or above) 

 RAM: 512MB or above, preferable 2GB 

 Hard disk: 500M 

 Monitor display: resolution 800ⅹ600, 256 colors, preferable 1024ⅹ768, true color 

 CD drive: CD-ROM/DVD driver 

 Port: available with Mouse port and USB2.0 port 

1.2 Installation Of UCanCam  

Don’t insert the USB dongle into the USB port of your computer before installation. To install your 

program and the USB dongle, please follow the procedures step by step. 

1 Put the installation disk into the CD-ROM driver. 

2 Run the file wtSetup.exe in the disk. 

3 The initialization interface is shown after running the program. See Fig.1-1. 

 

Fig. 1-1 

4 Then the welcoming dialog is shown (Fig.1-2). It is suggested to close other running programs 

during installation of UCanCam to avoid incorrect installation. (Press Alt +Tab to switch among 

programs.) 

 

Fig.1-2 

5 Click Next, and the License Agreement dialog is shown. (Fig.1-3) please read it carefully as this 

program is protected by copyright law, and any copying or spreading of the program without 
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authorization from UCanCam Software Technology Co., Ltd is subject to civil and criminal sanction. 

Click Yes to continue installation, and click No to exit installation. 

 

Fig. 1-3 

6 Click Yes and Choose Destination Location dialog is displayed. Click Next if you want to install the 

UCanCam in the default path (Fig.1-4).  

 

Fig. 1-4 

Click Browse if you want to change the installation path. Click OK to continue.  

 

Fig.1-5 

7 The program then asks whether you want to create a shortcut icon of UCanCam on the desktop. 

(Fig.1-6). It is suggested to select Yes. 
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Fig.1-6 

8 Click Next, and Start Copying Files dialog (Fig.1-7) is shown. The selected installation path and 

file are shown in the dialog. Click Back if you want to change the path and file. 

 

Fig.1-7 

9 Click Next to start copying files. (Fig.1-8) 

 

Fig.1-8 

10 After copying the file, the installation of USB dongle driver begins automatically.  

 

Fig.1-9 

11 After the installation of USB driver, the following dialog displays to indicate that the 
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installation has been completed. (Fig.1-10) 

 

Fig.1-10 

12 Click Finish and the dialog Setup Complete displays. (Fig.1-11) 

 

Fig.1-11 

14 Click Finish to finish installation.  

An icon  is formed on desktop. 

After confirming that the USB port of your PC is in normal working order, insert the USB dongle into 

the USB port of your computer, or connect the USB dongle with the computer through USB cable. 

You can now work with UCanCam. 

Remark：if you get the prompt “not find the dongle”, when run the UCanCam software. Please check 

wether the dongle is inserted in the USB port. if yes, then check the Device manager in your Windows 

system. If you see as Fig.1-12, that means the dongle is not installed successlly. You need to restart your 

system or reinstall the dongle driver. 

Open the directory which UCanCam exist in. and open the sub fold Drv, run the file dongleinstall.exe. 

after finish the installation process. you should see Fig.1-13 in Device Manager, it means the dongle is 

installed correctly.  

 

Fig.1-12                              Fig.1-13 

. 
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2. BRIEF INTRODUCTION TO UCANCAM  

2.1 Brief Introduction 

2.1.1 Application  

Ucancam, a special application software in CAD (Computer-Aided Design) and CAM 

(Computer-Aided Manufacturing), is widely used in such areas as advertisements, sign-making, gift 

manufacturing, decoration, art design, woodworking and mold-manufacturing. 

2.1.2 Features 

Two types of interface 

Both the standard and panel interface are available for users to choose according to your habits. 

Node editing 

Functions in node editing include: add, delete, disconnect, connect, close, convert to line, convert to 

curve, smooth, symmetry, align, start point, auto remove points, fillet, and vertical. 

Text Editing 

Text can be rotated, scaled, moved, sheared, arranged along curves, etc. and they can be edited 

again in text edit mode after these transformations. Besides, text input in a frame is also available, with 

automatic line feed. 

Serial number text 

This function is used with making some designs of serial number texts.  

Accurate drawing 

Accurate drawing is made easy by means of keyboard input. Feature points such as end points, 

midpoints, intersection points, perpendicular foot, and tangent points can be snapped. 

Editing Tools 

Various Editing Tools are provided, including trim, delete, offset, divide, close, simple slice, complex 

slice, Boolean operation and duplication. Geometrical-shape-transforming tools include move, rotate, 

scale, mirror, shear, perspective distortion, envelop distortion, twist distortion, push and pull distortion and 

auto nesting. 

Image tracing  

Images in various formats can be imported, converted, and stripped. Image tracing is available with 

Ucancam in order to extract contour. Angle degrees can be adjusted, and accurate tracing parameters 

such as cusp angle, trace error, fairy number, and threshold of line can be set. 

Other aided tools 

There are numerous viewing tools which are used to view objects from different viewing angles. 

Measuring tools for measuring length, angle, perimeter, size and other tools like ruler, guide line, 

notepad, and calculator are also available. 

Toolpath  

Tool paths are calculated quickly and accurately for NC machining. Ucancam provides a Tools 

Library where users can choose, edit, add or delete a tool. Various machining solutions are available.  

Users can apply toolpath walk simulation to check whether tool paths are valid and to preview machining 
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results. These simulation functions are also useful to reduce trial cutting times and cut down machining 

costs and help users to get valid and effective machining results. 

2.2 Interface 

 Both standard and panel interface are available for the users to choose according to your habits. 

2.2.1 Standard Interface 

Standard interface is the default interface of Ucancam. (Fig. 2-5) 

 

Fig. 2-5 

A. Title bar: displays file name or software name on the left; on the right are minimize button , 

maximize/back button  and close button . 

B. Menu bar: includes File, Edit, View, Draw, Text, Modify, Transform, Align, Node, Help, 

Surface and Tool Path. 

C Standard Bar: displays icons of commonly used tools 

D View Bar: displays icons of viewing tools. 

E Edit bar: displays icons of editing tools. 

F Edit mode tool bar: is for opening or closing tool bars and change editing modes. 

G Tool path: displays icons for tool path calculation. 

H Draw bar: displays icons for drawing simple shapes 

I Coordinates: are references to object positions. 

J Page: is the page size. 

K Drawing window: is the area for drawing. 

L Status bar: displays current operation status and parameters input. 

M Ruler: displays actual sizes of objects. It shows in the work interface in default setting. 

REMARK Click View->Rulers command to show or hide rulers.  

N X / Y Coordinates: Shows coordinates. 

O Show/Hide the Grids: Show or hide background Grids. 

REMARK Click View->Grids to show or hide background Grids. 

P Snap setting: Set the types of points to be snapped and control the show and close of the 

function. 

Q Color: is for setting color. 
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R Hide/Show: Show or hide tool paths. 

REMARK Click View->Tool path command to show or hide tool paths. 

Move the mouse onto any shortcut button, names of shortcut buttons will be shown automatically. 

2.2.2 Panel Interface 

Panel interface is another interface of Ucancam. With bars in tab form, Ucancam is operated easily 

and quickly as the interface layout is quite clear. (Fig. 2-6) 

 

Fig. 2-6 

A. Title bar              B. Menu bar          C. Shortcut button bar 

D. Status switch bar      E. View tools bar      F. Coordinates axes 

G. Page                 H. Drawing window    I. Status bar 

J. Rulers                K. X, Y coordinates    L. Show/Hide Grids 

M. Snap shortcut icon    N. Color              O. Show/Hide tool paths 

 

2.3 ToolBar Settings 

To switch between the above two kinds of interface, you should open ToolBar settings dialog. 

Click View->Toolbars, and the ToolBar Settings dialog displays. (Fig. ig.2-7) 

 
Fig 2-7 

Toolbar Style: is to select a style of the interface. 

Standard Toolbar Icon Style: is to select Large Icon style or Small Icon style in standard tool bar. 

Panel Toolbar Icon Style: is to select an icon style in panel toolbar. 

Toolbars: is to select one or more toolbars to be displayed in the interface. To hide a toolbar in the 

interface, deselect it.  



CHAPTER TWO                              BRIEF INTRODUCTION TO UCANCAM 

8 

You can save the settings by clicking , or by pressing the Enter key in the keyboard. 

Shortcut Icons 

Shortcut icons are shortcuts to menu commands. The table below outlines commonly-used shortcut 

icons in Ucancam. 

 

    ICON       FUNCTION        SHORTCUT KEY      LOCATION                                                                                     

 
Start a file Ctrl + N Standard Bar 

 
Open a file Ctrl + O Standard Bar 

 
Save a file Ctrl + S Standard Bar 

 
Print Ctrl + P Standard Bar 

 
Design Central  Standard Bar 

 
Import a file Ctrl + R Standard Bar 

 
Image tracing  Standard Bar 

 
Image stripping  Standard Bar 

 
Distance measure  Standard Bar 

 
Angle measure  Standard Bar 

 
Undo Ctrl + Z Standard Bar 

 
Redo Ctrl + Y Standard Bar 

 
Line   Curve Bar 

 
Polyline  Curve Bar 

 
Rectangle  Curve Bar 

 Circle  Curve Bar 
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Arc  Curve Bar 

 
Point  Curve Bar 

 Ellipse  Curve Bar 

 
Spline   Curve Bar 

 
Star   Curve Bar 

 Polygon   Curve Bar 

 
Combine curve  Curve Bar 

 
Arrow   Curve Bar 

 
Spiral  Curve Bar 

 
Wavy line  Curve Bar 

 
Rapid input  Text Editing Bar 

 
Convert to curves  Text Editing Bar 

 
String alone a curve  Text Editing Bar 

 
Trim   Modification Bar 

 
Offset   Modification Bar 

 
Linear slice   Modification Bar 

 
Rectangular Slice   Modification Bar 

 
Ellipse slice  Modification Bar 

 Parallel slice   Modification Bar 

 Circular slice  Modification Bar 
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Radial slice  Modification Bar 

 
Close  Modification Bar 

 Join  Modification Bar 

 Common  Modification Bar 

 Subtract  Modification Bar 

 Not common  Modification Bar 

 
Group Ctrl + G Modification Bar 

 
Ungroup Ctrl + U Modification Bar 

 
Direction  Modification Bar 

 
Divide   Modification Bar 

 
Expand  Modification Bar 

 
Duplication along a curve  Modification Bar 

 
Array duplication  Modification Bar 

 
Duplication along a line  Modification Bar 

 
Duplication along a arc  Modification Bar 

 
Duplication along a spiral curve  Modification Bar 

 
Move  Transform Bar 

 
Mouse  Transform Bar 

 
Scale  Transform Bar 

 
Horizontal mirror  Transform Bar 
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Vertical mirror  Transform Bar 

 Line mirror  Transform Bar 

 
Shear  Transform Bar 

 
Perspective distortion  Transform Bar 

 
Envelop distortion  Transform Bar 

 
Push & Pull distortion  Transform Bar 

 
Twist distortion  Transform Bar 

 
Auto nesting  Transform Bar 

 
Align on left Ctrl + Num4 Aligning Bar 

 
Align on right Ctrl + Num6 Aligning Bar 

 
Align to top Ctrl + Num8 Aligning Bar 

 
Align to bottom Ctrl + Num2 Aligning Bar 

 
Align on center Ctrl + Num5 Aligning Bar 

 
Horizontal aligning Alt + , Aligning Bar 

 
Vertical aligning Alt +. Aligning Bar 

 
Horizontal spacing Alt + [ Aligning Bar 

 
Vertical spacing Alt + ] Aligning Bar 

 
Make same width 

Ctrl + Alt + 

W 
Aligning Bar 

 
Make same height 

Ctrl + Alt + 

H 
Aligning Bar 



CHAPTER TWO                              BRIEF INTRODUCTION TO UCANCAM 

12 

 
Make same size 

Ctrl + Alt + 

A 
Aligning Bar 

 
Add a node  Node Editing Bar 

 
Delete a node  Node Editing Bar 

 
Disconnect  Node Editing Bar 

 
Connect  Node Editing Bar 

 
Close  Node Editing Bar 

 
Convert to line  Node Editing Bar 

 
Convert to curve  Node Editing Bar 

 
Cusping  Node Editing Bar 

 
Smooth  Node Editing Bar 

 
Symmetry  Node Editing Bar 

 
Node align  Node Editing Bar 

 
Start point  Node Editing Bar 

 
Auto remove points  Node Editing Bar 

 
Fillet  Node Editing Bar 

 
Vertical  Node Editing Bar 

 Tool management  Tool Path Bar 

 
Tool path output  Tool Path Bar 

 Profile machining  Tool Path Bar 

 
Area clearance  Tool Path Bar 
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3D engraving  Tool Path Bar 

 Midline machining   Tool Path Bar 

 
Drilling   Tool Path Bar 

 
Insert  Tool Path Bar 

 
Inlay  Tool Path Bar 

 
Prism machining  Tool Path Bar 

 
Intelligent machining  Tool Path Bar 

 
Embossing machining  Tool Path Bar 

 
Image relief machining  Tool Path Bar 

 
Toolpath walk simulation  Tool Path Bar 

 
Zoom window F6 View Bar 

 
Zoom in Page Up View Bar 

 
Zoom out Page Down View Bar 

 
Dynamic zoom F7 View Bar 

 
Fit to all F8 View Bar 

 
Fit to page F9 View Bar 

 
Pan view F10 View Bar 

 
3D view F12 View Bar 

 
Selection tools  Editing Mode Bar 

 
Text editing tools Ctrl + T Editing Mode Bar 
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Node editing tools Ctrl + K Editing Mode Bar 

 
Symbol library Ctrl + M Editing Mode Bar 

 
Draw basic vectors  Editing Mode Bar 

 
Editing tools  Editing Mode Bar 

 
Transform  Editing Mode Bar 

 
Align  Editing Mode Bar 

 
Tool path  Editing Mode Bar 

Toolbars 

Toolbars consist of commonly used commands. 

 

Fig.2-8a  Editing Mode Bar 

 

Fig.2-8b  Standard Bar 

 

Fig. 2-8c  View Bar 

 

Fig.2-8d  Curve Bar 

 

Fig.2-8e  Text Editing Bar 

 

Fig. 2-8f   Node Editing Bar 
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Fig.2-8g   Modification Bar 

 

Fig.2-8h   Transform Bar 

. 

Fig.2-8i  Aligning Bar 

 

Fig.2-8j  Tool Path Bar 

 

2.4 Design Central  

The function of Design Central includes setting page size, modifying elements property, digital 

positioning, condition select, modifying node coordinates and other operation. Key in parameters and 

press Enter to finish operation. Parameters come into force within 3seconds without pressing Enter. 

Click on the icon  on standard bar or click File->Design Central on menu bar. Design Central 

dialog can be shown or hidden. Double-click title bar of Design Central or press minimize button, Design 

Central dialog can be contracted, Double-click title bar of Design Center again or press maximize button, 

Design Central dialog can be shown .if you select object without opening Design Central. Design 

Central dialog will be display automatically. 

2.4.1 Page Size  

You can set page size at Design Central Fig 2-8  

 

Fig 2-8 

dict://key.0895DFE8DB67F9409DB285590D870EDD/minimize%20button
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1 Custom: you can design the size of page according to you need, you also can select one at drop 

down list .Fig 2-9  

 

Fig 2-9 

2 Width and height of page: is to show the width and height of page. You can key in the parameters 

of width and height according to you need. 

3 Direction: Portrait and Landscape of page. 

4.Origin: you can set the origin point on the center or left corner of the page. 

2.4.2 Select By Type  

Click Edit->Select By Type and a dialog is shown .Fig 2-10  

 

Fig 2-10 

Two styles of Select by in design central: Color and Type  

Type: you can select object directly, such as text .path and so on. You also can select objects by 

mouse with Type button in dialog,.when cursor become  select the object. In this way, all the objects 

with same type can be selected. 

Color: You can select objects by mouse. Click Color button in dialog, when cursor become  

select the object. In this way, all the objects with same color can be selected. 

Object-Type: Object-Type includes Circle, Point, Text, and Path. Click Circle, Point, Text, Path 

button in dialog, all the relevant type can be selected. 

Add-Select: After checking the “√”before Add-Select, you can select different type of object at 

app:ds:cursor
app:ds:cursor
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same time. Such as select rectangle first, after checking the “√”before Add-Select and clicking Circle 

button in the dialog, the rectangle and circle are selected at same time. This function is directed towards 

the objects in Object-Type. 

2.4.3 Element Property 

After selecting an object, you can check or modify its element property at Design Central Eg: select 

a circle, dialog is shown Fig 2-11  

 

Fig 2-11 

The center coordinate of circle, radius of it and layer is shown, key in parameters to change center 

coordinate of circle and radius of it. 

2.4.4 Figure Positioning  

Figure positioning function can accurately position the location and set the size of object.  

Select one or more objects, Figure Positioning dialog is shown automatically in design central, 

size and pivot points coordinate of objects is shown in dialog Fig 2-12a 

    

 

 

                         Fig 2-12a 

First pick pivot point ( Ucancam offer 9 pivot points to choose ) ,then key in width and height to 

change the size of object ( you can choose proportion ) finally key in x, y coordinate and press Enter to 

finish operation .the size of object and the location of it is changed.  

Eg : choose lower-left corner as pivot point , disable Proportion ,key in width( 100 ) ,height ( 100 ) , 

x-coordinate ( 0 ) , y-coordinate ( 0 )and press Enter to finish operation. The result is shown Fig 2-12b. 

The size is changed to be100*100.Lower-left corner coordinate is at the position (0, 0)  
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Fig 2-12b 

key increment step 
If the move in X and Y direction is 1mm each time, and objects move 1mm after selecting objects 

and pressing arrow keys on the keyboard.  

Rotate is for controlling the rotation of objects. Select an object, press the Ctrl key on the keyboard, 

and press the left or right arrow keys on the keyboard to rotate objects. Anti-clockwise rotation is 

achieved by pressing the left key and clockwise rotation is achieved by pressing the right key.
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3. BASIC OPERATIONS 
In this chapter, you will learn something about the basic operations of Ucancam. 

3.1 File Operation 

3.1.1 Open A File 

There are 3 ways to open a file: 

 Click on the icon  on Standard Bar 

 Click File->Open 

 Press Ctrl+O. 

Then the Open dialog displays. (Fig. 3-1) 

 

Fig. 3-1 

You can choose the path of the file, or enter the file name after File Name and you can preview this 

file in preview window. Click  after selecting the file name to open the file. 

REMARK The selected file can also be opened by double clicking the file or by pressing the Enter 

key on the keyboard. 

3.1.2 New A File 

Any of the following three ways can be chosen to create a new file. 

 Click on the icon  on Standard Bar 

 Click File->New   

 Press Ctrl + N 

3.1.3 Save A File 

There are three ways to save a file. 

 Click on the icon  on Standard Bar 

 Click File->Save. 

 Press Ctrl + S. 

In case of creating a new file or changing the path of a file, press Ctrl +Shift +S or click File->Save 
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As. Then the dialog Save As is shown. (Fig.3-2) 

 

Fig. 3-2 

You can select the saving path of the file in the drop down list Save As Type, and then input the 

name of the file and you can preview this file in preview window. After selecting the saving path and name 

of the file, click on  or press the Enter key to save the file. 

3.1.4 Import File 

Click File->Import File to import a file to the current page. 

The following are file formats that is compatible by Ucancam. (Fig.3-3) 

 

Fig.3-3 

Image File:  

BMP, JPG, JPEG, TIF, GIF, PNG. 

Vector File:   

AI File: Adobe Illustrator file format  

DXF File: The Drawing Exchange Format (DXF) enables the interchange of drawings between 

AutoCAD and other programs. 

EPS File: Encapsulated PostScript (EPS) is a standard file format for importing and exporting 

PostScript files. 

PLT File: PLT (also HPGL) created by Hewlett-Packard is the standard language for printing line 

drawings. HPGL is supported by many CAD, charting and word processing applications. 

TXT File: ASCII text file. 

There are 3 ways to import a file: 

 Click on the icon  on Standard Bar. 

 Click File->Import file in the menu bar 

 Press Ctrl + R. 
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Then Import File dialog displays. (Fig. 3-4) 

 

Fig. 3-4 

The only difference between Import File dialog and Open dialog is that you can select other file 

formats in Import File dialog. The file is opened after clicking on it and then clicking on  or 

pressing the Enter key. 

REMARK: Save DXF file at AutoCAD, before read it into, you should turn off the currently occupied 

document .otherwise; they will be read into the failure. save EPS at IS software, it is necessary to select a 

low version format, otherwise ,the file which will be read in will become redundant lines, arbitrary lines and 

so on . 

When you want to import a file whose format is not supported by Ucancam, please use other software 

such as windows paint and Photoshop to convert it to file formats compatible for Ucancam before importing 

the file. When you use AutoCAD,CorelDraw. Illustrator and other software, you should convert the vector 

graphics file to the format which is supported by Ucancam, and then operate the file. 

 

3.1.5 Export File 

You can save a file into other formats (e.g. DXF, PLT) compatible with other software. Choose the 

objects to be saved and then click File->Export on menu bar. Fig 3-5  

 

Fig 3-5 

You can select file save path at the drop down list of Save in. Key in file name at File name and 

select type of file at the drop down list of Save as type then press Save or press Enter on keyboard to 

save file. 

3.1.6 Export The Selected  

This function is to save the selected object, and make notes for it. 
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Select File->Export the selected on menu bar, a dialog is shown Fig3-6. Key in file name File name 

and select type of file at the drop down list of Save as type then press Save or press Enter on keyboard to 

save file. 

 

 

Fig3-6 

 

3.1.7 Print  

Before printing a document, it is necessary to install the windows printer driver, and you should 

confirm computer is connected with the printing devices. 

1. Print Setup  

Select File->Print Setup a dialog is shown, Fig 3-7 

 

Fig 3-7 

Print setting mainly divides into three parts: the printer, copies, position. If you set up many printers, 

printers connected, you should choose one of them from the drag down list of name. You can set the size, 

origin and orientation of the paper according to your needs. 

REMARK: Printer setting is different according to the brand and type of the printer used. Please refer 

to the instruction of your printer during setup. 

2. Print  

The Print dialog is displayed after clicking File->Print command (the shortcut key is Ctrl +P), or by 

clicking on the shortcut icon . Fig 3-8 
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Fig 3-8 

Copy: is the number of copies of the file to be printed. 

Scale: is the ratio of the size of the drawing to that of the paper. Select the value in the drag down list. 

Position: is the location of the page on the paper. 

The page can be previewed after clicking Preview in the Print dialog. (Fig.3-9) 

 
Fig.3-9   

 The page can be viewed after being zoomed in previewing module. (The page can be zoomed by 

four times) Click on  to print the file. Click on  or Esc key in the keyboard to exit 

previewing module.  

REMARK: The size of the page can be zoomed in by pressing the left mouse button on the page, and 

the page returns to normal size by pressing the left mouse button again. 

3.1.8 Notes 

You can make notes when you need. 

Click File->Notes, then the Notes dialog is shown  
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Making notes and press Ok to save notes, you also can press Cancel to cancel operation. 

REMARK: The notes can be saved with the file, when you open the file, you can check the notes you 

made.  

 

3.2 Viewing Tools  

 3.2.1 Zoom Window 

 Parts of a shape can be viewed closely through Zoom window. The following are three ways to 

start Zoom window. 

 Click on the icon  on View Bar. 

 Click View->Zoom window in the menu bar. 

 Press the shortcut key F6. 

Then the cursor changes into . Hold the left mouse button and move the cursor to form a view 

box; release the mouse button, then that part of the object is magnified.  

Click the right mouse button in the drawing window to end operation. 

3.2.2 Zoom In  

The page can be magnified through Zoom in function.  

There are three ways to start Zoom in operation. 

 Click the icon  on View Bar. 

 Click View->Zoom in on the menu bar. 

 Press the shortcut key Page Up. 

The Page is magnified by two times after each operation.  

3.2.3 Zoom Out 

The page can be minified through Zoom out function. This can be achieved in any of the following 

ways. 

 Click the icon  on View Bar. 

 Click View->Zoom out on the menu bar. 
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 Press the shortcut key Page Down. 

The Page is minified by half after each operation. 

3.2.4 Dynamic Zoom 

The page can be zoomed in or out through Dynamic zoom operation so that objects can be viewed in 

different sizes. This can be achieved by any of the following means. 

 Click the icon  on View Bar. 

 Click View->Dynamic zoom on the menu bar. 

 Press the shortcut key F7. 

Then the cursor changes into . Press the left mouse button, and the page is zoomed in by moving 

the mouse up, and is zoomed out by moving the mouse down. 

Click the right mouse button to exit Dynamic zoom operation. The cursor changes into an arrow and 

the Dynamic zooming effect is saved. 

REMARK: If you use 3D mouse, Dynamic zoom operation can be achieved by rolling the mouse 

wheel. The page is zoomed in by rolling the mouse wheel backward and is zoomed out by rolling the 

mouse wheel forward. 

3.2.5 Fit To All 

Selected objects can be displayed in the whole window through Fit to all function. First select the 

object(s), and then select one of the following ways. 

 Click the icon  on View Bar. 

 Click View->Fit to all. 

 Press the shortcut key F8. 

REMARK: If no objects are selected before enabling Fit to all operation, then all objects in the 

drawing window will be displayed in the whole view window after Fit to all operation. The following is an 

example when no object is selected.  

3.2.6 Fit To Page 

Object position in the page can be viewed through Fit to page function. 

There are 3 ways to start this function. 

 Click on the icon  on View Bar. 

 Click View->Fit to page on the menu bar. 

 Press the shortcut key F9. 

3.2.7 Pan View 

The whole Page can be moved so that you can view different parts of the drawing. This can be 

achieved through any of the following ways. 
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 Click on the icon  on View Bar. 

 Click View->Pan view in the menu bar 

 Press the shortcut key F10. 

Then the cursor changes into , and move the mouse with left button pressed to move the page.  

Click on the right mouse button in the drawing window to stop the moving.  

3.2.8 3D View 

You can view objects in 3D view by 3D view function.  

This can be achieved through any of the following ways. 

 Click on the icon  in View Bar. 

 Click View->3D view in the menu bar. 

 Press the shortcut key F12. 

After clicking on , the cursor changes into , press the left mouse button to view the object in 3D 

display. (Fig. 3-10) 

   

Fig. 3-10a (original)                       Fig. 3-10b (3D view) 

In 3D view mode, click the menu View->View Plan to display .Seven types of 3D view functions： 

Top view, Bottom view, Front view, Back view, Left view, Right view, and ISO view. Next we are 

to illustrate these functions by taking area clearance tool path as an example. (Fig. 3-11) 
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Fig. 3-11a (a rectangle’s tool path)                Fig. 3-11 b (front view) 

   

Fig. 3-11 c (left view)                          Fig 3-11d (top view) 

 

Fig. 3-11e (ISO view) 

 

Seven viewing methods are provided in the context menu, including Zoom window, Zoom in, Zoom 

out, Dynamic zoom, Pan View, Fit to all, Fit to page. Now let’s look at effects of these seven view 

functions in 3D view mode. (Fig. 3-12) 
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Fig 3-12a (Zoom window in 3D view)               Fig. 3-12b (Zoom In 3D view) 

   

Fig. 3-12c (Zoom out in 3D view)                Fig. 3-12d (Fit to all in 3D view) 

   

Fig. 3-12e (Fit to page in 3D view)              Fig. 3-12f (Pan View in 3D view) 



CHAPTER THREE                                        BASIC OPERATIONS 

29 

     

Fig. 3-12g (Dynamic zoom in 3D view) 

REMARK: In the 3D view mode, press keyboard arrow keys to move the page up, down, right and 

left. Press X, Y, Z key to rotate the page along X, Y, Z axis respectively. During rotating, if Shift key is 

pressed, rotation direction is anti-clockwise.  

3.2.9 Filled Display 

Selected objects can be filled with color through Filled display function. Select View->Filled display 

to start the operation. (Fig.3-13) 

      

Fig. 3-13a (original)                       Fig. 3-13b (filled display) 

REMARK: Click the color box in the status bar to display the color dialog. (Fig.3-25). Select a color to 

fill the object.  

 

Fig. 3-13 
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3.3 Basic Settings 

3.3.1 System Settings 

System setting: is aimed at making the operations more customizable to each user. 

Click View->System Settings on the menu bar, the System Settings dialog is shown. (Fig. 3-14) 

 

Fig. 3-14 

Set up guidelines 

Guidelines are vertical or horizontal lines that you can add anywhere in the drawing Window to help 

you measure, align, and position objects.  

You can display or hide the guidelines. You can also add, delete, move, and lock guidelines in the 

drawing window. (Fig. 3-15) 

   

Fig.3-15a put the mouse on the ruler         Fig. 3-15b guideline displays 

After putting the cursor on the ruler, press and hold the left mouse and then drag the guide line to the 

desired position. (Fig. 3-16) You can drag several guidelines by following the above steps. 

 

Fig. 3-16 
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It is very difficult to drag the guideline to a specific position with the method above, so guideline 

setting function is provided by Ucancam.  

This function can be started by clicking View->System Settings on the menu bar. Click on 

Guidelines. (Fig.3-17) 

   

Fig. 3-17                                   Fig. 3-18 

First enter the value of the guideline coordinate, e.g.180, in the dialog. (Fig. 3-18) 

Then, select Horizontal or Vertical before clicking on . Then a guideline is added in 

the working window. (Fig. 3-19) 

 

Fig. 3-19 

You can add more guidelines by repeating the steps above. (Fig.3-20). Click , and the 

added guidelines are shown in the drawing window. 

 

Fig. 3-20 

Guidelines can also be deleted, modified or hidden. 
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There are three ways to delete guidelines.  

 Click on the guideline and press the Delete key on the keyboard. 

 Put the cursor on the guideline, and when the cursor changes into  or , drag the guide 

line back onto the ruler. 

 Select the value of the guideline in Guidelines tool bar, the value is covered in blue (see 

Fig.3-20) and then click on . 

If you want to delete all horizontal and vertical guidelines, select the guidelines in Guidelines tool bar 

and click on . 

To modify a guideline, that is to change the position of a guideline, first select the value in the 

Guidelines, and click on . Then input a new value, and the guideline position is changed. 

The guidelines not used can be hidden by clicking View->Guidelines show/hide in the menu bar or 

by un-checking “√” before Show Guidelines. 

Grids setting 

Grids are a series of intersecting lines superimposed on an object to help you align and position 

objects accurately. You can display or hide grids at any time. You can have objects align automatically with 

the gridlines. You can set up the grid by specifying values for the frequency, which is the number of 

gridlines per unit of horizontal and vertical distance, or the spacing, which is the distance between the grid 

lines. The style of grids can also be changed. 

For more precise pixel editing at maximum zoom level, you can display a grid around each pixel. 

 

Fig. 3-21 

There are two kinds of grids in Ucancam: rectangular (Fig. 3-22) and radial (Fig. 3-23). The space of 

the rectangular grids can be adjusted by setting the horizontal and vertical spaces, and spaces of the radial 

grids can be adjusted by setting the angle and space between every two lines. 
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Fig. 3-22 Rectangular grids              Fig.3-23 Radial grids 

The background grids can be changed by any of the following two ways. 

 Add or un-checking the “√”before Show Grids;  

 Click View->Grids; or click on the icon  on Status bar. 

General settings 

General settings include Auto Save, Curve Accuracy, and Maximum Angle of Centerline. 

 

Fig. 3-24 

 Auto Save 

Auto save ensures that no data will be lost accidentally. Objects are saved in a file named 

backup.ucc and the file is in Ucancam Install directory. You can set the auto save intervals by typing in a 

value in Auto Save. 

 Curve Accuracy 

Show   

Displayed curves are more accurate if smaller values are entered in Show tool bar, but the accuracy 

has no effect on tool path.  

Machining 

If value of machining accuracy is smaller, tool paths calculated and the machining result are better.   

Snap  

Users can set the mouse snap accuracy. If the distance between the cursor and a point is less than 

the snap accuracy after snap function starts, the cursor changes into  and the point is snapped. 

 Maximum Angle of Centerline 

Maximum angle of centerline is the angle formed by any two adjacent centerlines. The centerlines 
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can be formed only when the angle exceeds the defined value. This setting is useful when processing 

midlines. 

As can be seen in Fig. 3-25, when the defined angle is 30 degrees, the centerline with an angle of 45 

degrees is shown as below (Fig. 3-26). But if the pre-defined angle is above 45 degrees, then the effect is 

not shown. 

    

Fig 3-25                         Fig. 3-26 

 View smooth transition 

If check the “View smooth transition”, when change viewing ,like as zoom window, zoom in zoom out, 

pan view, fit to all etc ,ucancam would swtich view by animation.  

 Show Unit 

If check the “Show Unit”, all the numeric edit box in all dialog would show the unit, like as “mm”, “inch” 

etc. 

                   

don’t Show Unit                   Show Unit ”mm” 

Default settings 

The default parameters can be set by clicking on . 

REMARK: It is recommended not to change the parameters unless there are special requirements. 

3.3.2 Snap Function 

Snap function is very helpful when we need to find perpendiculars, tangents, center lines, etc. We use 

the snap function to find the end points, adjacent points, middle point, center of a circle, intersection points, 

perpendicular points, tangent points, quartiles and grids. 

 The following dialog is displayed after selecting View->Snap Settings command or clicking on 
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 in the right corner of the status bar. (Fig. 3-27) Click  again, the dialog is hidden 

automatically. 

 

Fig. 3-27 

The feature points must be picked up first, otherwise the snap function will not work. Next we are 

going to see two examples to introduce the snap function. 

Example  

Now we want to draw a line with the rectangle’s one side’s midpoint as an end point of the line. The 

following is an example. 

1 First draw a rectangle. 

2 Then click on  in the lower right corner of the screen. The feature point tool bar is 

displayed in the bottom of the screen. (See below.) 

 

3 Tick the Mid.  

4 Put one end of the line outside the rectangle, and drag the mouse onto the side of the rectangle. 

When the cursor changes into “ ”, the midpoint of one side of the rectangle is found. (Fig. 3-28)  

5 Click the left mouse button, and the end point of the line is fixed in the mid point of the rectangle’s 

side. 

 

Fig. 3-28 

REMARK: The above points are not necessarily fit for all curves. For example, tangency points are 

applied to curves like arcs and splines, but not to rectangles; perpendicular is applied to line and rectangle 

but not to circle.  
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3.4 Other Tools 

3.4.1 Show/Hide 

This function is to avoid the influences of intersected or adjacent objects when drawing or editing an 

object. 

1. Select an object. 

2. Select Edit->Hide object on the menu bar.  

Then the selected object is hidden. (Fig. 3-29b) 

  

Fig. 3-29a                             Fig. 3-29b  

The hidden object reappears after clicking Edit->Show object. (Fig. 3-30) 

 

Fig. 3-30 

REMARK: This function is very useful when calculating tool paths. (Please refer to Tool Path in 

Chapter Ten.) 

3.4.2 Lock/Unlock 

When Lock function is enabled, an object’s position, shape and size are preserved.  

To lock an object 

1 Select the object to be locked. 

2 Click Edit->Lock/unlock on the menu bar. (Fig. 3-31) 
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Fig. 3-31a (click on lock/unlock)         Fig. 3-31b (the rectangle is locked) 

To unlock an object 

1 Select the object. 

2 Click Edit->Lock/unlock on the menu bar.  

3.4.3 Redraw 

You can improve the appearance of an object by removing unwanted speckles on it. You can enable 

this function by clicking View->Redraw on the menu bar or by pressing F5 on the keyboard.    

3.4.4 Measuring Tools 

Such functions as Distance measure, Angle measure, Perimeter measure, Area measure are 

available in Ucancam. 

Distance measure 

1 Click on the icon  on Standard Bar, or click Help->Distance measure on the menu bar.  

2 The cursor changes into .  

3 Pick the starting point and end point with the mouse. 

 

Fig.3-32 

REMARK: In case of measuring horizontal or vertical distances, press Shift key on the keyboard, 

and drag the mouse to move on horizontal or vertical direction. 

 

Angle measure 
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1 Click the icon  on Standard Bar, or click Help->Angle measure on the menu bar.  

2 When the cursor changes into , click on the angle peak and then move the cursor along one 

side of the angle. Click again. 

3 Continue to move the cursor until the cursor reaches the other side of the angle. Click the left 

mouse button again. 

4 Then angle degree is shown. (Fig. 3-33) 

 

Fig. 3-33 

 

Perimeter measure 

1 Click Help->Perimeter measure on the menu bar. 

2 The cursor changes into .  

3 Move  onto the shape to be measured. (Fig. 3-34) 

4 When the shape outline changes into dotted blue lines, click the left mouse button. 

The value of the perimeter of the shape is shown in the status bar in the lower left corner of the 

screen. 

 

Fig. 3-34 

 

Area measure 

Area measure is for measuring the size of a shape. 

1 Click Help->Area measure in the menu bar. 
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2 The cursor changes into . 

3 Move  onto the shape to be measured. 

4 When the shape is changed into a dotted blue line, click the left mouse button. (Fig. 3-35) 

5 The value of the size of the shape is shown in the status bar in the lower left corner of the status 

bar. 

 

Fig. 3-35 

The Maximum Inscribed Circle 

1 Click Help-> The maximum inscribed circle on the menu bar, or press “Alt +5” on the keypad. 

2 The cursor changes to . 

3 Move the cursor to the graph to be measured, and the graph is changed into a dotted blue line. 

4 Press the mouse left button. 

5 The measured value is displayed in the status bar. 

3.4.5 Calculator Notepad & Microsoft Paint 

Calculator, Notepad and Microsoft paint are available in Ucancam to make your operation easier. 

Calculator  

Calculator can be enabled after clicking Help->Calculator on the menu bar. (Fig. 3-36) 

Notepad 

Notepad can be enabled after clicking Help->Notepad. (Fig. 3-37) 

Microsoft paint 

Microsoft paint can be enabled after clicking Help->Microsoft paint on the menu bar. (Fig.3-38) 

       

Fig. 3-366                         Fig. 3-37 
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Fig. 3-38 

3.4.6 Help 

Ucancam offers a variety of ways to help you learn the application. 

 User manual 

 On line technical support 

 Help available in the Ucancam 

To use Help 

1 Click Help->Help in the menu bar. 

2 The Help dialog displays. (Fig. 3-39) 

 

Fig. 3-39 

3.4.7 Tip of The Day  

Tip of The Day includes basic functions and operation methods  

Open software, the dialog of Tip of the Day is shown automatically, (Fig 3-40) this dialog will not be 

shown automatically by un-checking“√” before Show tips at start .click Help->Tip of the day on menu bar. 

Press Next Tip you will get more information 
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Fig 3-40 

3.4.8 About Ucancam 

The information about Ucancam is available for users to know more about Ucancam. 

1 Click Help->About Ucancam on the menu bar.  

2 The dialog About Ucancam is displayed. (Fig. 3-41) 

 

Fig 3-41 

The dialog is closed by clicking  or pressing the Enter key on the keyboard. 
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4. DRAWING SHAPES 
 

Line, arc, circle, ellipse, Bezier curve, wavy line, combine curve, points, rectangle, star, spiral and 

regular polygons can be created and drawn in Ucancam.  

The following are the main features in Ucancam. 

 Point coordinates can be numerically input. 

 Automatically snap end points, midpoints, intersection points, tangency points, and other feature 

points. 

 Editing functions such as delete, offset, cut and trim, and Boolean operation functions such as 

join, common, not common and subtract are available. 

 Transformation tools like move, rotate, mirror, scale and aligning tools such as horizontal 

spacing, and make the same size are available. 

 Useful node editing tools. 

This chapter is devoted to a general introduction of creating and drawing geometrical shapes and 

using the symbol library. Objects with various shapes can be created after reading this chapter. 

4.1 Create Simple Shapes 

You can create simple shapes by entering coordinates on status bar. The origin (0, 0) is in the center 

of the page. 

Absolute coordinate: is to fix a relative point of origin at a certain position by entering two values of X 

and Y axis coordinates on status bar. Eg coordinate “100,200”, 100 is the values of X axis coordinate, 200 

is the values of Y axis coordinate. 

Relative coordinate: is to fix a relative point at a certain position by entering two values of X and Y 

axis coordinates on status bar, with another point as the origin. Eg Enter “r100, 200” on status bar, 100 is 

the values of X axis coordinate, 200 is the values of Y axis coordinate.  

Absolute polar coordinate: is to fix a point at a certain position by entering values of distance and 

angle on status bar. The values of distance represent the distance from the new point to origin. The values 

of angle is the angle made by rotating x-axis to the new point along x-axis forward direction，rotation 

direction is anti-clockwise. Eg Enter “100<30” on status bar, 100 is the values of distance, 30 is the values 

of angle. 

Relative polar coordinate: is to fix a point at a certain position by entering values of distance and 

angle on status bar, with another point as the origin. The value of distance is the distance from the new 

point to another point. The angle made by rotating x-axis to the new point along x-axis forward direction, 

rotation direction is anti-clockwise Eg: Enter “r100<30” on status bar. 100 is the values of distance, 30 is 

the values of angle. 

Expression: the values above can be instead by expression. Eg you can use “50+50, 100+100” 

instead of “100,200”  

4.1.1 Line 

1. Line 

a 2 points Line 
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Method 1 

1 Click the shortcut icon  on Curve Bar, or click Draw ->Line->Line in the menu bar. 

2 The words Start of line are shown in the status bar in the lower left corner.  

3 Input a point’s coordinates value, e.g. 10, 10, and press Enter key.  

4 Input a point’s coordinates value after the screen displays End of line in the status bar.  

5 Press the Enter key and a line is created. 

 

Fig. 4-1 

Method 2 

1 Click Draw ->Line->Line in the menu bar. 

2 Click in the drawing window to pick the position of the starting point and end point of the line, and 

press right mouse button to finish operation. 

You can reshape the line by transformation tools, such as moving, rotating, scaling etc. Detailed 

introduction to these transformations will be given in the following chapter 

REMARK: Horizontal line and vertical line can be drawn by pressing the Shift key while moving the 

cursor. A coordinate (X, Y) represents a point position；“X” and “Y” are separated by a comma. In Ucancam, 

you will need to input coordinate value in many operation. 

When you need to draw a precision curve, it is suggested to use method 1 to input point’s 

coordinates.  

b Parallel Line 

1 Draw a line  

2 Checking“√” before Parallel Line on status bar. 

3 Click in the drawing window to pick the position as the starting point of parallel line, and then move 

cursor to select line, when selected line change into blue, move mouse to pick the end point of 

Parallel line. 



CHAPTER FOUR                                      DRAWING SHAPES 

44 

 

c Start, Curve, Tangent 

1 Draw a circle, spline or circle. 

2 Checking“√” before Start, Curve, Tangent on status bar. 

3 Click in the drawing window to pick the position as the starting point of tangent, and then move 

cursor to select object, when selected shape change into blue, release left mouse button to finish 

operation. 

 

d 2 Curve Tangent  

1 Draw two shapes such as two circles. 

2 Checking“√” before 2 Curve Tangent on status bar. 

3 Select shape respectively, when selected shape became blue, release right mouse button to finish 

operation. 

 

e 2 Curve Vertical 

1 Draw two shapes such as two lines  

2 Checking“√” before 2 Curve Vertical on status bar. 

3 Select shape respectively, when selected shape became blue, release right mouse button to finish 

app:ds:respectively
app:ds:respectively
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operation. 

 

REMARK: Press Ctrl key on keyboard or click  by mouse to switch function on status 

bar.  

2. Polyline 

Method 1 

1 Click the shortcut icon  on Curve Bar, or click Draw->Line->Polyline in the menu bar. 

2 Input polyline’s points respectively according to prompt instructions in the status bar.  

3 Click the right mouse button to finish this operation and a polyline is created.  

 

Fig. 4-2 

Method 2 

You can also just click in the drawing window to define the points of the polyline. You can end the 

operation by clicking the right mouse button. 

REMARK:  

Horizontal or Vertical polylines can be drawn by pressing the Shift key while moving the cursor.  

Click menu Undo(Press the shortcut key Ctrl + Z), remove the last point or curve segment drawn. 

 

3. Double Polyline 

You can draw two parallel lines at a time with Double Polyline. 
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Fig. 4-3 

4.1.2 Arc 

1. Three-points 

Method 1 

1 Click the shortcut icon  on Curve Bar, or click Draw->Arc-> 3 Points on the menu bar. 

2 Input three points coordinates respectively in the status bar and press Enter. 

 

Fig. 4-4 

Method 2 

1 Click Draw->Arc-> 3 Points on the menu bar. 

2 Click in the drawing window to fix the position of the three points of the arc. 

2. Center, start, end 

1 Click Draw->Arc->Center, start, end in the menu bar. 

2 Input the coordinate in the status bar and press Enter. 

REMARK: Center means the center of the circle the arc is on. 



CHAPTER FOUR                                      DRAWING SHAPES 

47 

 

Fig. 4-5 

Drawing an arc by Center, start, end command is the same as drawing a 3-point arc, and the only 

difference is that the starting point is different. In Center, start, end, the first point is the center of the circle, 

the second point is the starting point of the arc, and the third point is the end point of the arc. 

3 Start, end, direction 

When applying this method while drawing an arc, the first point is the starting point of the arc, the 

second point is the end point, and direction is the end point tangent.  

4 Start, end, radius 

The first point is the starting point of the arc, the second point is the end point of the arc and the third 

step is to define the radius of the circle the arc is on.  

After inputting the values in the status bar, press Enter key to validate the operation.  

5 Tangential Arc 

You can draw an arc by a tangent. Follow the steps below. 

1 Draw a circle. 

2 Click Draw->Arc->Tangential Arc in the menu bar. 

3 The cursor becomes a pen. Drag the pen to the circle, and a blue line appears. (Fig. 4-6) 

4 Choose the position you want to put the arc, and then click the mouse button.  

5 Then drag the pen to a specific position according to the radius of the arc to be created. Then click 

again to fix the radius. 

6 Move the pen to define the arc length, and then click the mouse button to finish. 

 

Fig. 4-6 
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4.1.3 Circle 

Method 1 

1 Click the shortcut icon  in Curve Bar, or click Draw-> Circle on the menu bar.  

2 The words Center of circle are displayed in the status bar. 

3 Input a coordinate value, e.g.10, 10.  

4 Press the Enter key, and the position of the center of the circle is fixed.  

5 Input the value of the radius of the circle.  

6 Press Enter key and a circle is drawn.  

 

Fig. 4-7 

Method 2 

1 Click Draw-> Circle on the menu bar. 

2 Click in the drawing window to pick a point as the center of the circle. 

3 Move the mouse to define the radius of the circle.  

4 Click the left mouse button to finish drawing the circle. 

 

4.1.4 Ellipse 

Method 1 

1 Click the shortcut icon  on Curve Bar. 

2 Select Draw->Ellipse on the menu bar.  

3 The words Center of ellipse are shown in the status bar. 

4 Input a coordinate value to fix the position of the center of the ellipse. 

5 Enter a coordinate value to define the end point of the first axis of the ellipse. 

6 Enter the coordinate value of the length of the other axis of the ellipse.  
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Fig. 4-8 

Method 2 

1 Select Draw->Ellipse on the menu bar. 

2 Pick a point as the center of the ellipse by clicking in the drawing window. 

3 Click in another position to fix one axis of the ellipse. 

4 Click in a third point to define the radius of another axis of the ellipse 

4.1.5 Spline 

Method 1 

1 Click the shortcut icon  on Curve Bar, or click Draw->Spline on the menu bar.  

2 Input coordinate value respectively by following the instructions in the status bar. 

3 Finish the operation by clicking the right mouse button in the drawing window.  

 

Fig. 4-9 

Method 2 

1 Click Draw->Spline on the menu bar. 

2 Pick points respectively by clicking the left mouse button in the drawing window. 

3 Finish the operation by clicking the right mouse button. 

REMARK: Click menu Undo(Press the shortcut key Ctrl + Z), remove the last point or curve segment 

drawn. 

 

4.1.6 Combine Curve 

Combine curve is consisted of lines, arcs and splines. You can switch between line, 3 Point Arc, 
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Tangential Arc and Spline drawings. 

1 Click the shortcut icon  on Curve Bar，or click Draw->Combine curve on the menu bar.  

2 By default, the first shape is a line. You can switch between these shapes by clicking on options in 

the status bar. A combine curve example is shown in Fig. 4-11. 

   

Fig 4-10                             Fig. 4-11 

 

REMARK: Click menu Undo(Press the shortcut key Ctrl + Z), remove the last point or curve segment 

drawn. 

 

4.1.7 Points 

Method 1 

Click the icon  on Curve Bar, or click Draw->Point on the menu bar.  

Several points can be drawn at a time by inputting the coordinates of the points by following 

instructions in the status bar.  

Method 2 

Click Draw->Point on the menu bar, or pick points by clicking in the drawing window.  

4.1.8 Rectangles 

1. Rectangle 

Method 1 

1 Click the shortcut icon  on Curve Bar, or click Draw->Rectangle->Rectangle in the menu 

bar. 

2 Input coordinate value by following instructions in the status bar. 
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Fig. 4-12 

Method 2 

1 Click Draw->Rectangle->Rectangle in the menu bar. 

2 Pick two points by clicking in the drawing window. 

3 Finish this operation by clicking the right mouse button. 

2. Fillet rectangle 

There are two ways to draw a fillet rectangle: 

Method 1 

1. Click Draw->Rectangle ->Fillet Rectangle on the menu bar. 

2. Input two corner points’ coordinates and radius of fillet. 

   
Fig. 4-13                                Fig. 4-14 

Method 2 

1 Click Draw->Rectangle ->Fillet Rectangle on the menu bar. 

2 Pick two points as two of the rectangle’ corners by clicking in the drawing window. 

3 Get the correct radius by moving the mouse and clicking the left mouse button.  

REMARK: When using Method 1 to create a Fillet rectangle, you can move the cursor to get two 

different results. 

3. Chamfer rectangle 

Method 1 

1 Click Draw->Rectangle->Chamfer rectangle in the menu bar. 

2 Input points’ coordinates and chamfer value.  
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Fig. 4-15                                 Fig. 4-16 

Method 2 

1 Click Draw->Rectangle->Chamfer rectangle in the menu bar. 

2 Pick two points as a rectangle’s corners by clicking in the drawing window. 

3 Get a chamfer distance by clicking in the drawing window.  

The result is shown in Fig. 4-15. When moving the mouse to extreme points, the result is shown in 

Fig. 4-16 

 

4.1.9 Star 

Method 1 

1 Click the shortcut icon  in Curve Bar, or click Draw->Star in the menu bar. 

2 Input numbers of sides, center point coordinate, first radius and second radius of star respectively 

by following instructions in the status bar.  

Method 2 

1 Click Draw->Star in the menu bar. 

2 Input numbers of sides in the status bar. 

3 Pick the center, first radius and second radius of the star by clicking in the drawing window.  

The larger radius between first radius and second radius is regarded as star’s outer radius. You can 

select one radius as star’s outer or inner radius according to your need. 

 

Fig. 4-17 

REMARK: The Ratio of inner radius to outer radius of a standard star is 1:2. 
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4.1.10 Regular Polygon 

Method 1 

1 Click the shortcut icon  on Curve Bar, or click Draw->Regular polygon in the menu bar.  

2 Input the number of sides, the center point and radius respectively by following instructions in the 

status bar.  

 
Fig. 4-18 

Method 2  

1 Click Draw->Regular polygon in the menu. 

2 Input the number of sides in the status bar. 

3 Pick the center point of the regular polygon and radius of polygon by clicking in the drawing window. 

4.1.11 Arrow 

The shape of an arrow is determined by four feature points. (Fig.4-19) 

There are two ways to draw an arrow. 

Method 1 

1 Click the shortcut icon  on Curve Bar, or click Draw->Arrow in the menu bar. 

2 Input four feature points’ coordinates respectively by following instructions in the status bar. 

 

Fig. 4-19 

Method 2 

1. Click Draw->Arrow in the menu bar. 

2. Pick four points by clicking in the drawing window. 

3. Finish the operation by clicking the right mouse button. 
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4.1.12 Spiral 

You can draw two types of spirals in Ucancam: Archimedes spiral and Logarithm spiral. The 

distance between every two windings of Archimedes spiral is the same. The distance between every two 

windings of logarithm spiral increases as the number of windings increases. 

1. Click the shortcut icon  on Curve Bar, or click Draw->Spiral in the menu bar.  

2. The Spiral Parameters dialog (Fig. 4-20) is displayed.  

Archimedes spiral 

       
 Fig. 4-20                          Fig. 4-21 

Logarithm spiral 

       
Fig. 4-22                     Fig. 4-23 

When inputting data that is out of range, a warning message is displayed. 

 

   Fig. 4-24 
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4.1.13 Wavy line 

Various types of wavy lines such as Sinusoids, Swing Curves, Wavy Lines, Trapezium Polylines, 

and Wave Polylines are provided in Ucancam. 

   

Fig. 4-25a                                 Fig. 4-25b 

Wavy line parameters： 

Unit length: is the length of each wave 

Unit height: is the vertical distance between the wave top and the wave bottom. 

Top length: is the length of the wave top 

Top height: is the height of the wave tip 

1 Click the shortcut icon , or click Draw->Wavy Line in the menu bar.  

2 The dialog (Fig. 4-25) is displayed.  

3 Select one type of wavy line. 

4 Set the parameters and click on OK.  

5 Then a wavy line is drawn.  

The length and height of the wavy line can be adjusted, and the shape of the wavy line can be 

previewed. (Fig. 4-26) 

 

    

Fig. 4-26a                         Fig. 4-26b 
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Fig. 4-26c                         Fig. 4-26d 

 

    

Fig. 4-26e                        Fig. 4-26f  

 

 

Fig. 4-26g  

4.1.14 Hand Draw 

Besides the shapes above, you can also use your imagination to create any freeform shapes by 

Hand Draw. Follow the steps below. 

1 Click Draw->Hand Draw in the menu bar. 

2 Click and hold the left mouse button to draw freeform shapes. 
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Fig. 4-27 

4.1.15 Bounding Box 

Adding a bounding box to an object is useful for machining. Sizes of a bounding box are changed by 

parameter settings according to your needs. 

1 Select an object. 

2 Click Draw->Bounding box in the menu bar.  

3 The Bounding Box dialog is displayed. (Fig. 4-28) 

4 Select appropriate values. 

5 Click OK to finish the operation. 

 

 

Fig. 4-28 

Parameters 

Same size: The modifications of the bounding box in four directions are the same. 

Horizontal same: The modifications of the bounding box in the horizontal direction are the same. 

Vertical same: The modifications of the bounding box in the vertical direction are the same. 

Different size: The modifications of the bounding box in four directions are different. 
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Fig. 4-29 

 

4.2 Symbol Library 

Numerous kinds of symbols are provided in Ucancam, including trade marks, auto brands, animals 

and plants, furniture, human figures, etc. (The total number of the symbols in the symbol library is about 10 

thousand.)  

4.2.1 Show/Hide Symbol Library 

1. Click the icon  on Editing Bar, or click Draw->Symbol library on the menu bar.  

2. The Symbol Library dialog is displayed on the left of the drawing window. (Fig. 4-30) 

 

Fig. 4-30 

To hide the Symbol Library, there are three ways 

 Click  icon on Editing Bar. 

 Click Draw->Symbol library. 

 Click on the  button in the upper right corner of the dialog.  

4.2.2 Contents In Symbol Library 

Symbol Library is made up of four parts: Ucancam 98 library, Ucancam Utility library, Ucancam 

International library, and My library. Each of the four parts is further divided into smaller symbol libraries. 

Users can select the symbols from the Symbol library for use. (Fig. 4-31) 
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Fig. 4-31 

4.2.3 Selecting A Symbol  

You can browse the Symbol library and select a symbol which you need. All the symbols are divided 

into many groups according to their types.  

There are two ways to insert a symbol into the drawing window: 1) click on the Add button in the 

dialog bar, 2) insert the symbol into the drawing window by clicking on the symbol and dragging it into the 

drawing window. The symbol’s width, height and scale base are set by entering values in the Width and 

Height and Scale in the dialog.  

 

Fig. 4-32 

REMARK: Because there are too many types of symbols in Symbol library, it is suggested to get 

familiarized with the symbols first so that it is easier to find the desired symbols in Symbol library. 

4.2.4 My Library 

Users can create their own symbols and save them to My Library.  

1 Select an object. 

2 Click on Save button on Symbol library dialog bar. 

To delete a symbol from My Library 

1 Click on the symbol to be deleted. 

2 Click on Delete button in Symbol library dialog bar.  

Other operations in My library are the same as the operations in the Symbol library before. 
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Fig. 4-33 

REMARK: You can add or delete a symbol in My Library; symbols in other three symbol libraries can 

not be added or deleted by users.
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5. OBJECT OPERATION 
OBJECTS include points, lines, circles, polygons, texts, symbols, images and any other items in the 

drawing window. 

5.1 Select An Object 

5.1.1 Select With Mouse 

There are three ways to select an object with mouse. 

 Select an object by clicking the left mouse button 

1 Move the cursor onto an object. 

2 When the object is highlighted in dashed blue lines, click the left mouse button to select the object. 

The selected object is displayed in red. 

   

Fig. 5-1a (move the mouse onto the object)         Fig. 5-1b (the object is selected) 

REMARK: Hold down the Shift key, then click on each object you want to select, you can select 

multiple objects. (Fig. 5-2) To deselect an object, click on the object again. (Fig. 5-3) 

   

Fig. 5-2                                  Fig. 5-3 

 Select objects with a line  

1 Press the Ctrl key. 

2 Press and hold the left mouse button and move the mouse. 

3 A blue dashed line displays in the drawing window. Objects which intersect with the line are 

highlighted in dashed blue lines. 

4 Release the left mouse button to select objects. (Fig. 5-4) 
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Fig. 5-4a objects are highlighted               Fig. 5-4b the objects are selected  

 Select objects with a rectangle 

Method 1 

1 Press the left mouse button and move the cursor from left to right. (Note: the moving direction is 

from left to right.) 

2 Objects that are fully included in the blue rectangle are highlighted. 

3 Release the left mouse button, and these objects are selected. (Fig. 5-5) 

   

Fig. 5-5a A rectangle                    Fig. 5-5b the objects in the rectangle are selected 

Method 2 

1 Press the left mouse button and move the cursor from right to left. (Note: the moving direction is 

from left to right.) 

2 Objects that intersect with the rectangle are highlighted. 

3 Release the left mouse button and these objects are selected.  

5.1.2 Select By Menu Command 

1 Select all & Inverse Selection command 

To select all the objects in the drawing window, select Edit-> Select All (or press shortcut key Ctrl + 

A). (Fig. 5-6) 



CHAPTER FIVE                                       OBJECT OPERATION 

63 

 

Fig. 5-6 

If you select Edit-> Inverse Selection, then all the unselected objects are selected and all the 

selected objects are un-checked in the drawing window. (Fig. 5-7) 

   

Fig. 5-7a (select the unneeded objects)        Fig. 5-7b (after inverse selection) 

5.2 Transform Operation 

5.2.1 Move  

1 Select the object to be moved. When the cursor change in to “ ”the object can be move 

arbitrarily.  

    
                    Fig. 5-8                           Fig. 5-9 

REMARK: press Shift on keyboard, the object can be copied when it is moving  
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Fig. 5-10a                            Fig. 5-10b 

You also can move object by direction key on keyboard after selecting object by mouse. Keep on 

pressing direction key for a while can increase the speed of moving. 

2 Click icon  or click Transform->Move on menu bar, key in starting points coordinate (5, 5) in 

status bar and press Enter on keyboard. Then key in end point coordinate (150,150) in status bar and 

press Enter to finish operation Fig 5-11 

    

Fig. 5-11a                                Fig. 5-11b 

5.2.2 Scale 

To scale an object 

1 Select an object. 

2 Move the cursor onto the arrows in the four corners of the object. 

3 When the cursor changes into “ ”or “ ”, hold and drag the left mouse button.  

You can also scale the object by moving the cursor onto the arrows on the sides of the selected 

object; when the cursor changes into “ ”or“ ”, hold and drag the left mouse button. (Fig. 5-12) 
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Fig. 5-12a (dragging the corner)             Fig. 5-12b (dragging the sides) 

REMARK: Press and hold the Shift key, and drag one arrow on the highlighting box, and then the 

object will be scaled. 

  
Fig. 5-13                          Fig. 5-14 

You can also scale a selected object accurately by typing values.  

1 Click the icon  on Transform Bar, or click Transform->Scale. 

2 The Scale dialog is displayed. (Fig. 5-15) 

 

Fig. 5-15 

Old Bounding Box Size: displays the width and height of the original object. (X is the width, and Y is 

the height.) 

New Bounding Box Size: is for typing the new width and height value.  

Scaling Coefficient: is to scale an object by changing X and Y percentum.  

Keep X/Y ratio: If you enable Keep X/Y ratio, then the object will be scaled according to original 
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width to height ratio, which means changing the X value will cause the value in Y direction to change. If you 

un-checking “√” before Keep X/Y radio, then the change of the height and width of the object will not 

influence each other. 

Keep Original: If you enable it, then the original graph will be kept in the drawing window after its 

scale is changed; if you un-checking “√” before keep original, then the original graph will not be kept in the 

drawing window. 

Click the icon  or the Enter key to validate the setup. 

Note: Scaling function is not valid in Editing Input mode. 

     

Fig. 5-16a (select the graph)                  Fig. 5-16b (set the parameters) 

 

Fig. 5-16c (the effect after setup) 

As we can see from Fig. 5-16, the base point in scale transforming is the center of the rectangle, but 

you can change its location in Base Point list in Editing Input mode after clicking Text->Text Tools. 

You can input the coordinate value in X and Y, or you can also click the icon  and 

pick a coordinate point by clicking in the drawing window. 
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Fig. 5-17 

REMARK: The base point is the center of the object and the object is scaled with this point as the 

center. That is to say the base point is the only point whose position is not changed during scaling. 

Baseline is the central line of the object. The object is scaled with this line as the center line. In other words, 

the base line is the only line whose position is not changed during scaling. 

5.2.3 Rotation 

There are several ways to rotate a selected object. 

The commonly used method is shown below. 

1 Select an object  

2 Move the cursor into the highlighting box.  

3 When the cursor changes into “ ”, hold and move the left mouse button to rotate the object.  

You can also rotate an object by pressing the Ctrl key and the left/right keyboard arrow key. The 

object will be rotated anticlockwise by holding the left keyboard arrow key, and it will be rotated clockwise 

by holding the right keyboard arrow key. 

 

Fig. 5-18 

REMARK: The original object will be preserved in the drawing window if you press the Shift key while 

rotating the object. (Fig. 5-19) 
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    Fig. 5-19a (hold the Shift key)    Fig. 5-19b (the original object is preserved in the drawing window) 

 

To rotate an object accurately, there are two ways: Mouse rotate and Angle rotate. 

 Mouse Rotate 

1 Click the icon  in Transform Bar, or click Transform -> Mouse Rotate. 

2The words Start of rotation line are displayed in the status bar.  

3 Input the coordinate, e.g. (10, 10), and press Enter key. 

4 Then the words End of rotation line is shown in the status bar.  

5 Input the coordinate and press Enter, and the object is rotated.  

     

Fig. 5-20a (input the start rotation line)       Fig. 5-20b (after inputting the end rotation line) 

REMARK: The angle formed by the X-axis (the horizontal direction) and the rotation line is the 

rotation angle, and the starting point of the rotation line is the rotation center of the object. 

 Angle rotate 

1 Select Transform-> Angle rotate. 

2 The words Angle of rotation line are shown in the status bar.  

3 Type the value, e.g. 45, and press the Enter key. (Fig. 5-21) 

REMARK: After selecting the object, each press Space key will cause the object to rotate by 90 

degrees anticlockwise. 
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Fig. 5-21a (input the angle value 45 in the status bar)      Fig. 5-21b (after rotation) 

5.2.4 Mirror   

There are three ways to mirror an object: horizontal mirror, vertical mirror and line mirror. 

 Horizontal mirror 

Horizontal mirror is to mirror the object with its horizontal center line as the axis.  

1 Select an object. 

2 Click the icon  on Transform Bar, or click Transform-> Horizontal mirror.  

 Vertical mirror 

Vertical mirror is to mirror the object with its vertical center line as the axis.  

1 Select an object. 

2 Click the icon  on the Transform Bar, or click Transform-> Vertical mirror. 

    

Fig. 5-24a (original)            Fig. 5-24b (after horizontal mirroring) 
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Fig. 5-24c (after vertical mirroring) 

 Line Mirror 

Line mirror is also provided by Ucancam.  

1 Click the icon  in Transform Bar, or click Transform-> Line mirror. 

2 The words Start of mirror line are shown in the status bar.  

3 Type a coordinate value, e.g. 25, 25, and press Enter key.  

4 The words End of mirror line are shown in the status bar.  

5 Type a coordinate value, e.g. 100,100, and press the Enter key.  

6 The words Keep original object are shown in the status bar. Input “Y” to preserve the original 

object in the drawing window or “N” to remove the original object from the drawing window, and 

validate the command by pressing the Enter key. 

 

Fig. 5-25a (click Line mirror, and input the value of start of mirror line) 

 

Fig. 5-25b (Type the value of end of the mirror line)  
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Fig. 5-25c (the result) 

5.2.5 Shear 

To shear an object 

1 Select an object. 

2 Hold the Ctrl key and at the same time move the cursor onto the arrows of the highlighting box.  

3 When the cursor changes into or , hold the left mouse button and drag it. 

   

Fig. 5-28a (drag the mouse to shear the object)           Fig. 5-28b (after shearing) 

You can also shear an object accurately by using shear command.  

Click the icon  on Transform Bar, or click Transform->Shear to display a dialog. (Fig. 5-29) 

 

Fig. 5-29 

Horizontal shear: is used to set horizontal shear level. 

Vertical shear: is used to set the vertical shear level. 
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Keep originals: is used to preserve the original object in the drawing window after it is sheared. 

       

Fig. 5-30a (the original graph)           Fig. 5-30b (the effect after the object is inclined) 

5.2.6 Arc Fit 

You can change a Bezier curve, which is composed of small lengths, into a curve, which is composed 

of arcs. In this way, machining efficiency is greatly improved, because arcs take much less time to calculate 

during tool path output than Bezier. 

To apply arc fit to an object 

1. Select an object. 

2. Click Transform->Arc Fit in the menu bar. 

3. A dialog is displayed. 

4. Set the parameters, and click on OK to validate the setup. 

 

Fig. 5-31 

Parameters 

Tolerance: is the precision of arc fit. 

Keep Originals: is to preserve the original object in the drawing window if you tick it. 

REMARK: Arc Fit function is valid only to drawings which are composed of lines. It is not valid to 

images. 



CHAPTER FIVE                                       OBJECT OPERATION 

73 

 

5.2.7 Line Fit 

You can change a Bezier curve, which is composed of arc or curve, into a curve, which is composed 

of lines. That can be used for different needs. 

To apply line fit to an object 

1. Select an object. 

2. Click Transform->Line Fit in the menu bar. 

3. A dialog is displayed. 

4. Set the parameters, and click on OK to validate the setup. 

Parameters 

Tolerance: is the precision of line fit. 

Keep Originals: is to preserve the original object in the drawing window if you tick it. 

 

5.3 Align 

You can align several objects by using Align function. 

5.3.1 To Align An Object 

There are five ways to align an object: Align on left, Align on right, Align to top, Align to bottom 

and Align on center. 

Align on left: is to align several selected objects along the left side of the first selected object. There 

are three ways to enable this function: 

 Click the shortcut icon  on Aligning Bar. 

 Click Align->Align on left in the menu bar. 

 Press Ctrl + Num4. 
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Fig.5-32a (original)             Fig. 5-32b (align on left) 

Align on right: is to align several selected objects along the right side of the first selected object. 

There are three ways to enable this function. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align->Align on right in the menu bar. 

 Press Ctrl+Num6. 

   

Fig. 5-33a (original)                     Fig. 5-33 b (align on right) 

Align to top: is to align several selected objects along the top line of the first selected object. There 

are three ways to enable this function. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align->Align to top in the menu bar. 

 Press Ctrl+Num8. 

    

Fig. 5-34a (select the objects)            Fig. 5-34b (the effect after the object is aligned top) 
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 Align to bottom: is to align several selected objects with the bottom line of the first selected object. 

There are three ways to enable this function. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align->Align to bottom in the menu bar. 

 Press Ctrl+Num2. 

   

Fig. 5-35a (select the objects)       Fig. 5-35b (the effect after the objects are aligned 

bottom) 

Align on center: is to make the center of several selected objects the same as that of the first 

selected object. There are three ways to enable this function. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align->Align on center in the menu bar. 

 Press Ctrl+Num5. 

   

Fig. 5-36a (select the objects)          Fig. 5-36b (the effect after the object is aligned center) 

5.3.2 Vertical Aligning & Horizontal Aligning 

Vertical Aligning: is to align the vertical central line of several selected objects along that of the first 

selected object. 

There are three ways to enable this function. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align->Vertical aligning in the menu bar. 
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 Press Alt +V 

    

Fig. 5-37a (Select the objects)             Fig. 5-37b (After Vertical aligning) 

 

Horizontal Aligning: is to align several selected object along the horizontal central line of the first 

selected object. There are three ways to enable this function. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align-> Horizontal aligning in the menu bar. 

 Press Alt +H. 

    

Fig. 5-38a (select the objects)              Fig. 5-38b (after horizontal aligning) 

5.3.3 Space 

There are two types of Space: Horizontal spacing and Vertical spacing. 

Horizontal spacing: is to position the selected objects with the same space between each other 

horizontally.  

There are three ways. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align->Horizontal spacing in the menu bar. 

 Press Alt + [. 
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Fig. 5-39a (select the objects)               Fig. 5-39b (after horizontal spacing) 

 

 Vertical spacing: is to position several selected objects with the same space between each other 

vertically. There are three ways. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align->Vertical spacing in the menu bar. 

 Press Alt +]. 

     

Fig. 5-40a (select the objects)                   Fig. 5-40b (after vertical spacing) 

REMARK: The number of the selected objects must be over two. 

5.3.4 Same Size 

To make the size of several selected objects the same, you can click Transform->Scale, but this 

method requires too much work and time. You can make it easier by using Align ->Same Size command 

on the menu bar. There are three ways to enable this function. 

 Click the shortcut icon  on Aligning Bar. 

 Click Align-> Same Size on the menu bar. 

 Press Ctrl+Alt+A. 
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Fig. 5-41a (select the objects)              Fig. 5-41b (the effect) 

There are two additional functions in Ucancam: Same Width and Same Height. 

Same Width: is to make the width of the selected object the same as that of the first selected object. 

There are three ways to start this function. 

 Click the shortcut icon  in Aligning Bar. 

 Click Align-> Same Width in the menu bar. 

 Press Ctrl+ Alt+ W. 

   

Fig. 5-42a (select the objects)               Fig. 5-42b (the effect) 

Same Height: is to make the height of the selected objects the same as that of the first selected 

object.  

There are three ways to enable this function. 

 Click the shortcut icon  in Aligning Bar. 

 Click Align-> Same Height in the menu bar. 

 Press Ctrl+ Alt+ H. 
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Fig. 5-43a (select the object)                    Fig. 5-43b (the effect) 

 

5.4 Perspective Distortion 

1 Select the graph. 

2 Click on the icon  on Transform Bar or click Transform->Perspective Distortion.  

3 A net is displayed.  

  

Fig. 5-44                              Fig. 5-45 

4 Hold and drag the four panes in the corners of the net, and the object is distorted. (Fig. 5-48) 

Press the right mouse button or the Esc key to exit the operation. 

5.5 Envelop Distortion 

This is used to change the form of the selected object.  

1 Select an object 

2 Click the icon  on the Transform Bar or click Transform->Envelop distortion. 

3 A box with several nodes and a dialog are shown. (Fig. 5-46) 
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Fig. 5-46                             Fig. 5-47 

4 Select a shape from the dialog Select Envelop Type (on the right of the drawing window). (Fig. 

5-47) 

REMARK: The object resumes the original shape by clicking ; to save the new shape, 

click . 

Then you can change the shape of the object by dragging the nodes on the selected frame.  

 

Fig. 5-48 

Double click on a node of the frame to delete it; click on a point of the box to add a node. 

When selecting several nodes at a time, the selected nodes will be filled with the color blue, and then 

you can move the selected nodes together by mouse. (Fig. 5-49) 

   

Fig. 5-49a (select several nodes)                   Fig. 5-49b (the effect) 
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5.6 Push And Pull Distortion 

Push and Pull Distortion is to distort an object by pulling or pushing its base point. 

1 Select an object. 

2 Click on the icon  on Transform Bar or click Transform->Push and Pull Distortion. 

3 Pick the base point by clicking in the drawing window. (Fig. 5-50) 

   

Fig. 5-50                       Fig. 5-51 

 

4 Move the cursor onto the base point 

5 When the cursor changes into +, hold and drag the left mouse button to distort the object. (Fig. 

5-51) 

6 Click the right mouse button or the Esc key on the keyboard to exit the operation.  

5.7 Twist Distortion 

This is to distort an object by rotating its base point. 

1 Select an object. 

2 Click on shortcut icon  on Transform Bar or click Transform->Twist Distortion. 

The base point is shown. (Fig. 5-52) 

   

Fig. 5-52                             Fig. 5-53 

3 Move the cursor onto the base point. 

4 When the cursor changes into +,hold and drag the left mouse button to change the object into 

desired shape. (Fig. 5-53) 
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5 Press the right mouse button or the Esc key to exit the operation. 

5.8 Auto Nesting 

Several objects with various shapes and sizes can be arranged in a selected shape to save material.  

The following is an example. 

 

Fig. 5-54 

1 Select all the objects. 

2 Click on the icon  on Transform Bar or select Transform->Auto Nesting  

3 The cursor changes into .  

4 Move the cursor onto the side of the shape of stock such as a rectangular. 

5 When the rectangular turns light blue, click the left mouse button.  

6 Then the dialog Auto Nesting is shown. (Fig. 5-55) 

 

Fig. 5-55 

Parameters 

Precision: is the precision of auto nesting.  

Kerf Width: is the width of kerf which equal to tool diameter 

Clearance: you can set remain which is the shortest distance between the original part and part after 

machining. (Do not set the value too small; otherwise the material can not be machined properly.) 

Step Angle: After setting step angle, objects will be automatically rotated according to the angle  

Iteration count: the more iteration count you set, the better effort you will get .otherwise increase 
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iteration count, and you will spent more time to calculate it. 

Mirror: some objects can be automatically mirrored to save the material during auto nesting. 

In hole nest: some objects can be automatically nest in hole  

Keep old: keep old object after nesting  

After setting the parameters, click on OK to validate it.  

 

Fig. 5-56 

5.9 Undo& Redo 

5.9.1 Undo 

Ucancam lets you cancel actions through any one of the following three methods. 

 Click on the shortcut icon  in Standard Bar. 

 Click Edit->Undo in the menu bar. 

 Press the shortcut key Ctrl + Z. 

   

Fig. 5-57a                             Fig. 5-57b  

5.9.2 Redo  

There are three ways to repeat an action. 

 Click on the shortcut icon  in Standard Bar. 

 Click Edit->Redo in the menu bar. 

 Press Ctrl + Y. 



CHAPTER SIX                                            GRAPH EDITING 

84 

6. GRAPH EDITING 
Editing operations include: Copy, Paste, Cut, Delete, Trim, Divide, Offset, Expand, Join, Common, 

Not common, Subtract, Group, Ungroup, and Duplication.  

6.1 Copy Paste Cut 

To copy an object 

1 Select an object. 

2 Select Edit->Copy or press Ctrl + C. 

3 Select Edit->Paste or press Ctrl + V. 

4 The words Please input base point is shown in the status bar. (Base point is the center of the 

object.) 

5 Type a value (e.g. 10, 10) or just click in the drawing window to define the position of the base point.  

   

Fig. 6-1a (copy the selected object)               Fig. 6-1b (paste) 

6.2 Delete 

To delete an object 

1 Select an object. 

2 Click Edit->Delete or press Delete key in the keyboard.  

    

Fig. 6-2a (before deletion)                Fig. 6-2b (after deletion) 

6.3 Trim 

To trim an object 

1 Select an object. 
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2 Click on the icon  or click Modify->Trim. 

3 The cursor then changes into scissors. Move the scissors onto the object, and the part pointed by 

the scissors will turn light blue. 

4 Click the left mouse button, and that part of the object will be trimmed off. Click the right mouse 

button or press the Esc key to end the operation.  

  

Fig. 6-3a (original graph)                Fig. 6-3b (after being trimmed) 

 

 
Fig. 6-4 

REMARK: If you press the Ctrl key while trimming, then the selected part where  appears will 

be separated from the original object. 

The other function of Trim is to extend a line to intersect with another object such as a line or a 

curve/arc/combine curve/spiral. If there is no curve or line to intersect with it in the direction of the dragged 

line, then the line cannot be extended.  

To extend a line 

1 Select the line to be extended. 

2 Click on the icon  or click Modify->Trim. 

3 Place the cursor in the blank area between the line and the other object which is going to intersect 

with it. 

4 When a broken line appears between the line and the object, click the left mouse button. 

5 The line is extended and intersects with the object (In the example below, the object is also a line.).  
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Fig. 6-5a (original)                  Fig. 6-5b (after being extended) 

REMARK: The number of objects to be trimmed must be two or above, and in the case of trimming a 

compound graph, the graph must be ungrouped first.  

 

6.4 Offset 

Offset means to extend the object inward or outward by the same distance. 

1 Select an object. 

2 Click on the icon  on Modification Bar or select Modify->Offset.  

Then the following dialog is displayed. (Fig. 6-6) 

 

Fig. 6-6 

There are two ways to offset an object: Inner and Outer. 

Offset corners type includes: Rounded, Sharpened, Chamfered. 

    

Fig. 6-7a (sharpened)                 Fig. 6-7b (rounded) 
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Fig. 6-7c (chamfered) 

In Fig. 6-8, there is a curve; we now apply outer offset to it with a distance of 10mm. Then the effect is 

shown in Fig. 6-9. 

  

Fig. 6-8                              Fig. 6-9 

6.5 Expand 

Expand is to offset an object both inward and outward at the same time. 

To expand an object 

1 Select an object. 

2 Click on the icon  on the Modification Bar or click Modify->Expand. 

3 Input the distance in the status bar, and press Enter. 

   

Fig. 6-10a (select the object)            Fig. 6-10b (after being extended) 
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6.6 Close 

Close is to link several curves (two or above) with lines. 

Take the following as an example. 

 

Fig. 6-11 

 

1 Select all the objects 

2 Click on the icon  in Modification Bar or click Modify->Close. Then the following dialog is 

displayed. (Fig. 6-12 

 

Fig. 6-12 

 

3 Type a value in Max Close Distance.  

Note: If the distance between two end points exceeds Max Close Distance, then the two points will 

not be linked. 

4 Click on Close button in the dialog.  
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Fig. 6-13a               Fig. 6-13b (Two points are linked.) 

Take another example. If we set the value of max close distance at 100mm, and click on the button 

Close in the dialog, then the result is shown in Fig. 6-14b. (All the points are linked) 

       

Fig. 6-14a                    Fig. 6-14b 

 

6.7 Direction 

To change the direction of an object 

1 Select an object whose direction is to be changed. 

2 Click on the icon  on Modification Bar or click Modify->Direction. 

3 The cursor changes into “ ”. Put the cursor on the object.  

4 The object will turn into broken lines and its direction is shown. (Fig. 6-15)  

5 Click the left mouse button on the object to display the Flipping of Curve dialog. (Fig. 6-16) 

6 Click on  to reverse its direction, and click on  to remain its direction 

unchanged. (Fig. 6-17) 
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Fig. 6-15 

    
Fig. 6-16                                   Fig. 6-17 

Click the right mouse button in the drawing window or the Esc key in the keyboard, and then the 

displayed direction will be hidden. 

6.8 Delete Overlay Loop 

This function is to delete the overlaid parts of one graph or text in order to form tool path. 

1 Select the object to be operated. 

2 Select Modify->Delete overlay loop. (Fig. 6-18) 

   

Fig. 6-18a (original)                Fig. 6-18b (after deleting overlay loop) 

 

6.9 Slice 

Slice is to separate a graph into several smaller ones, and a close graph will remain close after this 

operation and the unclosed ones remain unclosed.  
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There are two types of Slice: Simple slice and Complex slice. Simple slice can be divided into linear 

slice, rectangular slice and ellipse slice; complex slice can be classified into parallel slice, circular slice and 

radial slice.  

6.9.1 Simple Slice 

Linear slice 

1 Select an object. 

2 Click on the icon  on Modification Bar or click Modify->Simple slice->Linear slice.  

3 Draw a line on the selected object. (The line must traverse the object.) 

   

Fig. 6-19a (original)                   Fig. 6-19b (after being sliced) 

4 Move one part of object by mouse. 

Rectangular slice 

1 Select an object. 

2 Click on the icon  on Modification Bar or click Modify->Simple slice->Rectangular slice.  

3 Draw a rectangle on the selected object, and the object is sliced. 

Note: The sides of the rectangle should intersect with the selected object. 

    

Fig. 6-20a (original)                        Fig. 6-20b (after being sliced) 

 Ellipse slice 

1 Select an object. 

2 Click on the icon  on Modification Bar or click Modify->Simple slice->Ellipse slice. 

3 Draw an ellipse on the selected object and the object is sliced.  
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Note: The border of the ellipse must intersect with the graph. 

   

Fig. 6-21 (original)                       Fig. 6-22 (after being sliced) 

6.9.2 Complex Slice 

Parallel slice 

1 Select an object and click on the icon  on Modification Bar or click Modify->Complex 

slice->Parallel slice.  

2 Then a dialog is shown. The parameters include line angle, preserve space, and remove space. Line 

angle is formed by the slicing line and the horizontal line; preserve space is the width of the preserved 

parts; remove space is the space between each two preserved parts.  

3 Click on the icon  in the dialog or press the Esc key and the right mouse button 

simultaneously. 

           

Fig. 6-23 (dialog)                         Fig. 6-24 

 

Circular slice 

1. Select an object. 

2. Click on the icon  on the Modification Bar or click Modify->Complex Slice->Circular slice.  

3. A dialog is displayed (Fig. 6-25).  

The parameters include start radius, preserve space and remove space.  

4 After setting the values, click OK to validate the operation and click Cancel in to quit the operation. 
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Fig. 6-25                            Fig. 6-26 

Radial slice 

1. Select the object to be sliced. 

2. Click on the icon  on Modification Bar or click Modify->Complex Slice->Radial Slice.  

3. A dialog is displayed. (Fig. 6-27)  

The parameters include: start angle, keep angle and remove angle. Start angle is for setting the 

position of the radial area; keep angle is the angle of the preserved parts; remove angle is the angle 

between each two preserved parts.  

After typing the values, click OK to validate the operation and click Cancel or press the right mouse 

button to exit the operation. 

                     

Fig. 6-27                           Fig. 6-28 

6.10 Divide   

Divide is to separate an object into several parts by defining dividing points. 

To divide an object 

1 Select the object to be divided. 

2 Click on the icon  in Modification Bar or click Modify->Divide. 

3 The words Please input the number of divisions are shown in the status bar.  

4 Type a value and press Enter.  
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Fig. 6-29a (original)                       Fig. 6-29b (after being divided) 

6.11 Boolean Operation 

Boolean operation includes join, common, not common and subtract.  

Take the following graph as an example. 

 

Fig. 6-30 

Join 

1 Select the two objects to be joined. 

2 Click on the icon  on Modification Bar or click Modify ->Join. The result is shown below. 

 

Fig. 6-31 

Common 

1. Select two objects. 

2 Click on the icon  on Modification Bar or click Modify-> Common. The result is as follows. 
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Fig. 6-32 

Subtract 

1 Select the two objects. 

2 Click on the icon  on Modification Bar or click Modify-> Subtract,  

If you select then rectangle before selecting the circle, the result is shown in Fig. 6-33; if you select 

the circle first and then select the rectangle, the result will be as shown in Fig. 6-34. 

   

Fig. 6-33                            Fig. 6-34 

 

Not common 

1 Select the two objects. 

2 Click on the icon  on Modification Bar or click Modify ->Not Common. The following is the 

result. 

 

Fig. 6-35 
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6.12 Duplication 

Array Duplication 

1 Click on the icon  on Modification Bar or click Modify-> Array Duplication. 

2 A dialog is displayed. (Fig. 6-36) 

 

Fig. 6-36 (circular duplication) 

Two types of Array Duplication: Reclangular Duplication and Circular Duplication. 

Parameters in rectangular duplication include: 

Row: is the number of rows. 

Col: is the number of column  

Row Space: is the space between every two rows. 

Column Space: is the space between every two columns. 

Angle: is formed by the bottom row and the positive direction of X axis. 

3 After entering the values, click on the icon  or the Enter key to finish the setup.  

 

Fig. 6-37a (draw a circle) 
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Fig. 6-37b (set the value)                    Fig. 6-37c (the result) 

REMARK: The value of row space and column space can be negative numbers; it means that the 

duplicated objects will be placed in the negative X-axis direction. 

Parameters in circular duplication include: 

Center point: is to define the position of the center point of the circle. You can input the value directly; 

or you can click on , and then click in the drawing window to fix the center point position of 

the circle.  

Total: is the total number of the objects to be duplicated. 

Angle: is the angle formed by the first and last duplicated object on the circle. 

Rotating object: is to rotate the duplicated object 

   

Fig. 6-38a (original) 

    

Fig. 6-38b (set the parameters)                  Fig. 6-38c (the result) 

Duplication along a curve 

This is to duplicate the selected object along a curve. 
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1 Draw a curve. 

2 Select the object to be duplicated.  

3 Click Modify-> Duplication along A Curve. 

4 The words Please select a curve are shown in the status bar.  

5 Move the cursor onto the curve. 

6 When the cursor changes into , click the left mouse button. A dialog is displayed. (Fig. 6-39) 

 

Fig. 6-39 

Parameters 

Rigidity space array: The object is duplicated along the curve with the same distance between each 

two objects. 

Rigidity amount array: The amount is the total amount of the objects duplicated to the end of the 

curve with the same distance between each two objects. 

Flexibility adjacent array: Check “Auto duplication” and then the object is duplicated along the curve 

with their centers on the line. If you do not check “Auto duplication”, then the object is duplicated according 

to the actual amount you set in the Amount list. The object is duplicated with no space between each two 

of them. 

Flexibility center-to-center array: The object is duplicated along the curve with the same distance 

between the centers of each two objects. 

Flexibility stretch array: The object is duplicated automatically with objects all along the curve. 

7. After setting the parameters, click on  to end the setup. 

 

Fig. 6-40a (select the object) 
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Fig. 6-40b (set the parameters)               Fig. 6-40c (the result) 

Duplication along a Line 

This is to duplicate an object along a line. 

1 Select the object to be duplicated. 

2 Click on the icon  on Modification Bar or click Modify ->Duplication along a Line.  

3 A dialog is displayed. (Fig.6-41) 

 

Fig. 6-41 

Parameters 

Space: is the distance between each two duplicated objects. 

Amount: is the number of the duplicated objects. 

Scaling: is the ratio of the size of the first duplicated object and the last duplicated object to that of 

the original object. 

Refresh: is to validate the setting. 

4. Set the values and click on Refresh. 

5. Click in the drawing window to pick up the position of the first duplicated object. Move the mouse to 

the desired position. 
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Fig. 6-42a (enter the value)               Fig. 6-42b (the result) 

Duplication along an Arc 

1 Select the object to be duplicated. 

2 Click on the icon  on the Modification Bar or click Modify-> Duplication along an Arc.  

3. A dialog is displayed. (Fig. 6-43) 

 

Fig. 6-43 

Parameters 

Angle: is formed by every two duplicated objects close to each other. 

Keep Ratio Angle: by selecting this function, the duplicated objects are positioned vertically to the 

arc. 

Amount: is the number of the duplicated objects. 

Scaling: is the ratio of the size of the first duplicated object and the last duplicated object to that of 

the original object. 

Refresh: is to validate the setting. 

 

Fig. 6-44a (original) 
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Fig. 6-44b (enter value)                    Fig. 6-44c (the effect) 

Duplication along a Spiral Curve 

1 Select the object to be duplicated. 

2 Click on the icon  on Modification Bar or click Modify-> Duplication along a spiral curve.  

3 A dialog is displayed. (Fig. 6-45) 

 

Fig. 6-45 

Parameters 

Space: is the distance between each two duplicated objects. 

Keep space ratio: means the space between the objects is adjusted automatically. 

Amount: is the number of the duplicated objects. 

Scaling: is the ratio of the size of the first and last duplicated object to that of the original object. 

Refresh: is to validate the setting. 

4 Enter the values and then click the left mouse in the drawing window to pick up the position of the 

center of the spiral. 

5 Move the mouse until the desired result is reached. Then click the left mouse button in the drawing 

window to end the setup. 
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Fig. 6-46a (original)              Fig. 6-46b (input parameters) 

 

Fig. 6-46c (the effect) 

 

6.13 Group & Ungroup 

You can group several objects so that they behave as one unit. Grouped objects can be deleted, 

moved or transformed as a single entity. You can add objects to an existing group, and ungroup them when 

you want to edit then individually. 

To group several objects 

 1 Select the objects to be grouped. 

 2 Click on the icon  on Modification Bar or select Modify->Group.  

Then the objects are grouped. 

To ungroup several objects 

 1 Select the objects to be ungrouped. 

 2 select Modify->Ungroup.  

Then the objects are ungrouped. 

 

6.14 Block 

Block is to group objects of different properties to be one object. Objects that can be blocked include 

graphs, tool paths, text, etc. 

Click Modify->Block on the menu bar to block the objects. Click. Modify->Unblock on the menu bar 

to unblock the objects.  
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6.15 Object Color 

 

You can change the color of the object by 

1 Select the object to be edited. 

2 Click on  or the drag down list (the color list is also available on the right of the status 

bar).  

3 The color selection box is shown. (Fig. 6-47) 

 
Fig. 6-47 

To choose other colors, click on Other Color. 
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7. TEXT EDITING 
This chapter is devoted to a general introduction of the usage of text editing in Ucancam. 

7.1 Text Input 

7.1.1 Rapid Input 

To improve text imputing speed, you can apply Rapid Input.  

1 Click on the icon  on Text Editing Bar or click Text->Rapid Input. 

2 A dialog is displayed. (Fig. 7-1) 

 

Fig. 7-1 

3 Input the text, and click on .  

4 The words Start of text are displayed in the status bar. Input the coordinate value and press Enter 

or just click in the drawing window to designate the starting position of the text, and then the text is 

shown in the designated place.  

  

Fig. 7-2 (input the text)                Fig. 7-3 (after inputting the start coordinate) 

REMARK: You can copy the text in other software (e.g. Word) to the dialog Rapid input by pressing 

Ctrl + C and Ctrl + V.  
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7.1.2 Editing Input 

There are three ways to enable this function. 

 Click on the icon  on the Editing Tool Bar. 

 Click Text->Edit Tools. 

 Press Ctrl + T. 

Then the editing input dialog is displayed on the left of the screen. 

Click the left mouse button in the drawing window to start text input. (Fig. 7-4) 

 

Fig. 7-4 

REMARK: Properties of the text can be set either before or after input of the text. 

7.2 Text Editing 

7.2.1 Font Installation 

You can install font which you need .method of installation: open control panel and find font then copy 

it to font file. 

7.2.2 Font Selection 

Ucancam provides you with various font types. But note all the font properties should be set after 

entering Editing Input mode. 

 

Fig. 7-5 
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7.2.3 Character Height & Width 

1 Select the word(s) to be edited. 

2 Input values in the list of Character width and Character height or select the value from the drag 

down list. (Fig. 7-6) 

                

Fig. 7-6a (select char width)        Fig. 7-6b (select char height) 

REMARK: The value which has been input will be automatically remembered in the drag down lists. 

When inputting the value of char height, the value of char width will change in proportion automatically, but 

when inputting character width, the value of char height will not change. The range of the value of char 

width and height should be within 0 to 99999. 

7.2.4 Overstriking & Incline 

1 Select a text. 

2 Click on the icon , then the selected text will be overstriked. Click on . Then the text will be 

inclined. (Fig. 7-7) 

 

Fig. 7-7 

7.2.5 Vertical Text Flow 

1. Select a text. 

2. Click on the icon . (Fig. 7-8) 
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Fig. 7-8 

7.2.6 The Same Height 

1 Select a text. 

2 Click on the icon , then the selected text will change the height, keep the same height.  Fig. 

7-9) 

  

Fig. 7-9a                            Fig. 7-9b 

7.2.8 Character Space & Line Space 

Character space means the distance between each two characters; line space is the distance 

between every two lines.  

To set character space and line space 

1 Select the characters. 

2 Input the value in the list of Char Space and Line Space or select from the drag down list. (Fig. 

7-11) 

 

Fig. 7-10 

 

7.2.9 Align 

1 Select the words to be aligned. 
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2 We can see four icons:  (align on left),  (align on center),  (align on right), and  

(fill).  Click on one of them. The result is shown below.  

   

F7-11a (align on left)                        Fig. 7-11b (align on center) 

   

Fig. 7-11c (align on right)                      Fig. 7-11d (fill) 

7.2.10 Text Rotate  

 Input the value of angle 

 1 Select the text to be rotated. 

 2 Enter the Editing Input mode.  

 3 Type a value in char angle or select a value from the drag down list. (Fig. 7-12) 

 

Fig. 7-12 

7.2.11 Base Height 

Sometimes the text is not on the same horizontal line. (e.g."22”) In this case, we can adjust the 

distance between the base line and the character by setting the parameters of baseline. Input the value in 

the dialog or select a value from the drag down list. (Fig. 7-13) 

 

Fig. 7-13 

Steps are as follows 

1 Select one or more objects. 
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2 Type a value in the Base height list or select a value from the drag down list. 

 

Fig. 7-14 

7.3 Text Along A Curve 

Text Along A Curve is to put a text on a curve. There are two ways to enable this function. 

Method 1  

1 Input a text, and draw a curve.  

2 Select both the curve and the text. 

3 Click the icon  on Text Editing Bar or click Text->Text along A Curve. 

   

Fig. 7-15a (select the text and the curve)        Fig. 7-15b (the text is put along the curve) 

As we can see in Fig. 7-14b, the length of the text is not equal to that of the curve, so the text is not 

put in full length on the curve. Enter Editing Input mode and adjust the value in Char Space, the result is 

shown in Fig. 7-16 

 

Fig. 7-16 
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In Fig. 7-16, we can see that there is a little red circle under the first letter U. Move the cursor onto the 

little red circle. When the cursor changes into “ ”, hold the left mouse button and drag it to pick the 

starting point of the text on the curve again. (Fig. 7-17) 

 

Fig. 7-17 

You can also put the text under a curve or in reversed direction.  

 

Fig. 7-18 

Deselect On/Under a curve to put the text under the curve. 

 

Fig. 7-19 

Tick Reverse, and the text will be put in reverse direction. (Fig. 7-20) 

 

Fig. 7-20 

Method 2 
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1 Type a text and draw a curve. 

2 Enter the Editing Input mode.  

3 Put the cursor onto a curve. 

4 When the cursor changes into , move the cursor to pick the starting point of the text on the curve.  

5 Click the left mouse button, and the glinting cursor appears on the curve.  

6 You can input the text on the curve now. (Fig. 7-21) 

   

Fig. 7-21a (the cursor changes into )              Fig. 7-21b (input the text) 

After inputting the text, you can set the properties of the text with the same method as in method 1. 

REMARK: The curve is not displayed in graph edit mode but only in text edit mode. 

7.4 Hollow Character 

This function is to make hollow characters. Follow the steps below: 

1 Exit Editing Input mode 

2 Select the text to be hollowed. 

3 Click Text->Hollow Characters. 

4. A dialog is displayed. (Fig. 7-22) 

 

Fig. 7-22 

Parameters 

Offset Distance: the value by which the text is to be extended. 

Offset corners type: is the shape of the corner, including Acute angle and Round angle. 

Keep original objects: is to preserve the original text in the drawing window after operation. 
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Fig. 7-23a (original)                    Fig. 7-23b (the effect of hollow character) 

7.5 Convert To Curves 

1 Exit the Editing Input mode. 

2 Select the text. 

3 Click on the icon  on Text Editing Bar or click Text->Convert to Curves.  

   

Fig. 7-24a (select the text)           Fig. 7-24b (the text is changed into individual units) 

If we group two or more text and then ungroup them, the text can be changed into individual units. 

   

Fig. 7-24c (input two lines of texts)          Fig. 7-24d (select the texts to group them) 
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Fig. 7-24e (ungroup)             Fig. 7-24f (the text is changed into individual units) 

If a text and a graph are grouped and then ungrouped, the text can also be changed into individual 

units. (Fig. 7-25) 

 

   

Fig. 7-25a (select text and graph)               Fig. 7-25b (ungroup) 

 

Fig. 7-25c (the text is changed into individual units) 

REMARK: The text which has been changed into graphs should not be adjusted using text editing 

tools.  

7.6 Serial Number Text 

When we are making cards, we need to change the serial numbers on the card. With Serial Number 

Text function, this is made easier.  

1 Select Text->Serial Number Text 

2 A dialog is displayed. (Fig. 7-26) 
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Fig. 7-26 

Parameters  

●Serial number input 

Start: is the value of the first serial number. 

End: is the value of the last serial number. 

Step: is the value gap between each two adjacent serial numbers. 

Total: is the total amount of the serial numbers 

Format: is the digit of the serial numbers 

 

●Text input 

Front text: is the text before the serial numbers. 

Back text: is the text after the serial numbers. 

 

●Array 

Amount per row: is the amount of serial number text in each row. 

Amount per column: is the amount of serial number text in each column. 

Row space: is the space between each row. 

Column space: is the space between each column. 

Click on Preview to preview the effect. 

Click on OK, and input the start coordinate of the text in the status bar or simply click the left mouse 

button in the drawing window to fix the position of the first serial number text. 

        

Fig. 7-27a (input the value) 
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Fig. 7-26b (input the coordinate)                Fig. 7-27c (the effect) 

7.7 Text Symbol 

Variuos symbols and special characters can be inserted into text with Text Symbol in Text Tool. 

It include: Latin, Digital, Unit, Punctuation, Math, Special Character, Greece, Arrow, Table. 

1.Click Text->Insert Text Symbol in the menu bar, and a dialog appears on the left. 

2.Select on a symbol, click <Insert> button or double click a symbol, get the character in the drawing 

window.  

 

                                     Fig. 7-28 

7.8 Replace 

You can replace a letter with another one with Replace. Follow the steps below. 

1 Choose the letters. 

2. Click Text->Replace in the menu bar, and a dialogue box appears. (Fig. 7-29) 

3. Enter the letter or some sequence letters to be replaced in FIND WHAT; enter the letter or letters in 

REPLACE WITH. And click on OK. 

Then the letters are replaced. 
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Fig. 7-29 

7.9 Single Stroke Text  

Follow the steps below. 

1 Choose a letter or several letters 

2 Click Text->Single Stroke in the menu bar  

3 select minimum branch length and press ok, and then single stroke is created. 

4 Press Cancel to cancel operation. 

 

 

Fig. 7-30 

7.10 Text In A Closed Shape  

You can input text in a closed shape.  

1 Draw a closed shape 

2. Click  to enter Text mode 

3. Move the cursor to the shape. When the cursor changes to , click the left mouse button. And 

then you can type in text in the closed shape.
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8. NODE EDIT 
With Ucancam, you can draw lines, arcs, circles, ellipses, curves, etc. The shape of a curve is 

determined by four points: two end points and two controlling points. (Fig. 8-1) The shape of a curve can 

be changed by changing the position of the end points and the controlling points. 

 

 

Fig. 8-1 

Functions in node editing include: Add, Delete, Disconnect, Connect, Close, Convert to line, 

Convert to curve, Smooth, Symmetry, Node align, Start point, Auto remove points, Fillet, Chamfer, 

and Vertical.  

 

8.1 Node Selection And Move 

There are two ways to select a node. 

 To select one node, click the node or click the right mouse button to display the context menu 

in node editing mode. 

 To select several nodes, drag the mouse to form a box around the nodes, or click the nodes 

one after another while pressing the Shift key, and end the operation by releasing the Shift 

key. 

To move a node 

1. Select the node 

2. Click the left mouse button on the node. Hold and drag the mouse to move the node. (A node 

can be moved horizontally or vertically by pressing the Ctrl key at the same time.) 

 

8.2 Add & Delete A Node 

To add a node 

1 Enter the node editing mode. 

2 Click on the location where you are going to put the new node.  

3 A black dot appears in this position.  

4 Click the icon  on Node Editing Bar or click Node->Add. 

5 A new node is added in the selected position.  
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You can add a node by double clicking the left mouse button. (Fig. 8-2, Fig. 8-3) 

   

Fig. 8-2                          Fig. 8-3 

To delete a node 

1 Select a node. 

2 Click on the icon  on Node Editing Bar or click Node->Delete.  

Nodes can also be deleted by double clicking the left mouse button. (Fig. 8-4 is the effect after 

deleting two nodes from Fig. 8-2.) 

 

Fig. 8-4 

To add or delete several nodes at the same time 

1 Select several nodes.  

2 Click on the icon  on Node Editing Bar or click Node->Delete. 

REMARK: Nodes of circles and ellipses can not be deleted.  

8.3 Cusping & Smooth 

Cusp and smooth are the two types of relative positions between nodes and their controlling points. 

When one of the two controlling points is moved, the other one is moved accordingly to make the curve 

smooth. A node and its two controlling points are not put on the same line by applying Cusping function. 

When moving one of the two controlling point, the other one is not moved, thus making the curve acute. 

Smooth and Cusping are only applied to Bezier. 

To cusp a node 

1 Enter node editing mode 

2 Select the node to be edited. 
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3 Click on the icon  on the Node Editing Bar or click Node->Cusping.  

4 Move the controlling points by dragging the mouse. (Fig. 8-5) 

 

Fig. 8-5 

To smooth a node 

1 Enter node editing mode 

2 Select the node. 

3 Click on the icon  on Node Editing Bar or click Node->Smooth. 

  

Fig. 8-6                         Fig. 8-7 

You can change the shape of the curve by changing the position of the controlling points. (Fig. 8-7) 

REMARK: Smooth function should only be applied to acute nodes, and Cusping operation is only 

valid to smooth nodes. 

8.4 Symmetry 

1. Enter node editing mode. 

2. Select the nodes. 

3. Click on the icon  on the Node Editing Bar or click Node->Symmetry. 

4. Move the controlling points by dragging the mouse.  
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Fig. 8-8 

8.5 Align 

Align is to align the selected nodes horizontally or vertically.  

1 Enter node editing mode 

2 Select the nodes. 

3 Click on the icon  on Node Editing Bar.  

4 A dialog in Fig. 8-9 is shown.  

5 Select the way you want to align the nodes, and then click OK.  

 

Fig. 8-9 

  

Fig. 8-10 (horizontal align)                   Fig. 8-11 (vertical align) 

REMARK: The number of nodes to be aligned must be two or above; otherwise the operation is 

invalid. 
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8.6 Convert To Line & Convert To Curve 

Convert to line 

1 Enter Node Editing mode by clicking  on the right of the screen or by clicking 

Node->Node Tools on the menu bar.  

2 Click on the shape to display its nodes.  

3 Select a node. 

4 Click on the icon  on the Node Editing Bar or click Node->Convert to line.   

Then the curve between the selected node and the node right after it is converted to a line. 

 

Fig. 8-12 

REMARK: When the selected node is the end point of the curve, the curve between the end point 

and the node right before it is changed into a line. 

 

Convert to curve 

1 Enter Node Edit mode 

2 Select the nodes to be edited. 

3 Click on the shortcut icon  on the Node Editing Bar or click Node->Convert to curve.  

8.7 Disconnect & Connect 

To disconnect a node 

1 Select a node. 

2 Click on the icon  on Node Editing Bar or click Node->Disconnect.  

3 Then the node is disconnected. 
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Fig. 8-13a (original)                Fig. 8-13b (after disconnecting the node) 

To connect nodes 

1 Select the nodes to be connected. 

2 Click on the icon  on the Node Editing Bar or click Node->Connect.  

      

Fig. 8-14a (original)                       Fig. 8-14b (after being connected) 

REMARK: The connect function is only valid when connecting two starting points, or two end 

points or one starting point and one end point. 

8.8 Close 

Close is to connect the starting point and the end point of a curve to change the curve into a close 

one. 

1 Select the curve to be closed by clicking on one of its nodes. 

2 Click on the icon  on Node Editing Bar. 

3 Select Node ->Close. 
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Fig. 8-15a (original)                Fig. 8-15b (after being closed) 

8.9 Start Point 

1. Select a node. 

2. Click on the icon  on the Node Editing Bar or click Node->Start point. 

REMARK: This function is valid only when the object to be edited is a close graph. 

8.10 Auto Remove Points 

With Auto Remove Points function, the number of nodes in a graph can be reduced without 

changing the shape of the graph, thus making node editing easier. 

1 Select the nodes to be removed. 

2 Click on the icon  on Node Editing Bar or c 

lick Node->Auto Remove Points. The nodes are removed from the graph. 

    

Fig. 8-16 (original)                 Fig. 8-17 (after removing some points) 

You can apply this operation to either all the nodes or only some of the nodes. 

8.11 Fillet 

1. Select a node. 

2. Click on the icon  on Node Editing Bar or click Node->Fillet. 

3. A dialog (Fig. 8-18) is displayed.  

4. Input the value of radius (Radius is the radius of the arc.) and click on OK.  
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Fig. 8-18                    Fig. 8-19b (the effect) 

REMARK: This function is only valid when editing acute angles. 

8.12 Vertical  

With this function, an acute angle can be changed into a right angle.  

1 Select the node to be edited. 

2 Click on the icon  on the Node Editing Bar or click Node->Vertical. 

  

Fig. 8-20a (original)                      Fig. 8-20b (the effect) 

8.13 Node Position 

You can give an accurate position to the node which you selected .select a node, change it’s 

X-coordinate and Y-coordinate at Design Central. Fig 8-23 

                                 

Fig 8-23
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9. ADDITIONAL OPERATIONS 

9.1 Image Processing 

The system provides many image processing functions such as image scanning, image tracing, 

image stripping, adjusting brightness, adjusting contrast, and converting into grayscale image.  

9.1.1 Image Scanning 

Image scanning function can help you import images through scanner. Make sure that your computer 

and scanner are connected before scanning. Put the object in the scanner. Click File->Select Scanner in 

the menu bar, and then the following dialog is displayed. 

 
Fig. 9-1 

The names of the scanners are displayed in the dialog, select one and click on select. Then click 

File->Image Scan in the menu bar, and a dialog is displayed. Select the object to be scanned and start 

scanning. (Fig.9-2) 

 

Fig. 9-2 

9.1.2 Adjust Brightness 

Select the image to be edited, then click File->Image processing->Adjust brightness in the menu 

bar and a dialog is displayed. Drag the slider in the dialog to adjust image brightness value.  

9.1.3 Adjust Contrast 

Select an image in the drawing window, then click File->Image Processing->Adjust Contrast in the 

menu bar, and a dialog is displayed. Drag the slider in the dialog to adjust the contrast of the image.  

9.1.4 Convert Into Grayscale Image 

Grayscale image is composed of pixel of binary digit, with 256 kinds of gray colors.  
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Select an image in the drawing window, then click File->Image Processing->Convert into 

Grayscale Image in the menu bar, and a multicolor image is changed into a grayscale image. (Fig. 9-3 and 

Fig. 9-4) 

   

Fig. 9-3 (multicolor image)               Fig. 9-4 (grayscale image) 

9.1.5 Image Tracing 

Image tracing is a very important command and plays an important part in image engraving. It refers 

to getting the parameters of the contour of the image. 

Select an image, and click on the shortcut icon  on Standard Bar or click File->Image 

Processing->Image Tracing in the menu bar, then the following dialog is displayed. (Fig. 9-5) 

          

Fig. 9-5                         Fig. 9-6 

Parameters 

Cusp angle: When tracing an image, the contour contains some cusp angles, and if we set the value 

at 60, then the angles above 60 degrees will be smoothed into curves, and those below 60 degrees will not 

be changed. 

Trace error: The smaller the value of trace error is, the more accurate the contour is, and the longer 

the time of calculation is. 

Fairing number: The bigger the value is, the better the effect is. 

Approximal precision: The value is to set approximate image borders. 

Threshold of line: If the bending level of the curve is less than this value, then the curve will be 

replaced by a line. 

Level of despeckle: When importing images, there are probably unneeded spots left on the image. 
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In order to remove these unwanted spots, we can set the level of despeckle to make the image clearer. 

Center line: is to draw the center line of the contour of the graph. 

Default: After changing the parameters, if you want to resume the default value, you should click on 

Default, and then the value returns to the default value. 

Preview: Click on  to observe the result of the image tracing process. 

The following is an example. 

1. Click File->Import in the menu bar to import a file in BMP format. (Fig. 9-7) 

 

Fig. 9-7 

2. Select the image, and click on the shortcut icon  in Standard Bar or click File->Image 

Processing->Image Tracing in the menu bar. Then a dialog is displayed. (Fig. 9-9) 

3. Keep the default value, and click on OK. Then the dialog Image Tracing is displayed. (Fig. 9-10) 

  

Fig. 9-9 

 

Fig. 9-10 

4. Wait for a moment, and then the effect is shown. (Fig. 9-11) 
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Fig. 9-11 

5. The image is changed into vector graph after being processed, and you can now edit any part of it. 

When choosing the center line, the effect is shown below. (Fig. 9-12) 

 

Fig. 9-12 

9.1.6 Image Stripping 

This is to display an image in stripe form, and the stripped image can be used in engraving. See the 

following example. 

1 Import an image and click on the shortcut icon  on Standard Bar or select menu 

File->Image Processing->Image stripping in the menu bar. Then the following dialog is displayed. (Fig. 

9-13) 

 

Fig. 9-13 

Parameters 

Height: the height of every strip of the image. 
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Space: the space between every two stripes. 

Accuracy: the higher the value is, the more accurate the image is. 

Additional parameters: 

Add box: A box is added around the processed image if this function is started. 

Inverse: The inversed image will be processed. 

Offset: is the distance between the sides of the box and the edge of the image. 

2 Keep the default value, and click on OK. Then the dialog Image Stripping dialog is displayed. (Fig. 

9-14) 

 

3 Wait for a moment, and then the effect is shown. (Fig. 9-15) 

 

Fig. 9-15 

9.1.7 Threshold 

Import an image, and then click on File->Image Processing->Threshold in the menu bar.  

   

Fig. 9-16 (Before Threshold)          Fig. 9-17 (After Threshold) 

9.1.8 Despeckle 

You can clean out spots on the images with Despeckle.  

Select the image, and then click on File->Image Processing->Despeckle in the menu bar. 
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9.1.9 Invert 

You can invert the color of the image by clicking File->Image Processing->Invert in the menu bar. 

   

Fig. 9-18 (Before inverting color)                Fig. 9-19 (After Inverting) 

9.1.10 Image Undo 

You can cancel actions by clicking File->Image Processing->Image Undo in the menu bar .so that 

you need not to import file again.  

9.2 Context Menu 

We have mentioned this function in the chapters above, and now we are going to make a summary of 

it. 

There are four types of functions regarding context menu: selection, node edit, text edit and 3D view. 

Selection: The functions in selection include text edit, node edit, group, ungroup, filled display, delete, 

hide, lock/unlock, and object properties. When no objects are selected, the context menu displayed is 

shown in Fig. 9-20; when an object or more are selected, the context menu displayed is shown in Fig. 9-21. 

The last two operations are automatically memorized by the system. 

   

Fig. 9-20                      Fig. 9-21 

 

Node Edit: The functions in node edit context menu include add (a node), delete (a node), break, join, 

close, convert to line, convert to curve, cusping, smooth, symnerty, align, start point, auto remove points, 

fillet, vertical.  

Click the right mouse button after selecting the curve. Select Node tools command in the context 
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menu, and then pick the nodes to be edited, and finally click the right mouse button. Then the functions 

mentioned above in node editing are displayed. (Fig. 9-23) 

 

Fig. 9-23 

Text Edit: The functions in text edit context menu include rapid input, serial number text, and filled 

display. (Fig. 9-24) 

 

Fig. 9-24 

REMARK: These functions can be enabled by clicking shortcut keys.  

9.3 Layer Edit 

In UCancam, you can create shapes on different layers. You can add or delete layers so to perform 

operations on many objects at the same time, while none of the operations interfere with each other. 

The functions of the layers are as below. 

1 You can hide or show the layer as you desire.  

2 You can do modifications on shapes in one layer, while the shapes in other layers are not modified. 

3 You can set the color to be the same in one layer, and make shapes without the need to change the 

color. 

4 You can name one layer so that you can find the layer easily when you need. 

Click View->Layer Bar on the menu bar, you can show or hide layer edit tool bar.  

 

Layer Edit Tool Bar 
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LAYER EDIT DIALOG
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10. TOOLPATH 
Engraving is to carve characters or graphs on such materials as two-color board, metal, wood, and 

stone. CNC machine controls the motion of X, Y and Z axis under the instruction of the computer, and 

drives high-speed tool or laser gun to move on the material, achieving the desired result. 

After designing an artwork, the artwork’s tool paths are calculated by ToolPath functions in Ucancam. 

The data of the tool path is then sent to the control box for machining.  

Various types of machining are provided by Ucancam, including profile machining, area clearance, 3D 

engraving, midline machining, drilling, inlay machining, prism machining, intelligent machining, embossing 

machining, image dot machining, image relief machining, etc. 

10.1 General Knowledge About Tools 

Proper tools should be chosen when machining different materials with various rigidities in order to 

achieve the desired result and not to break tools. You can select the tools in the tool library. 

Click on the shortcut icon  on Tool Path Bar or click Toolpath->Tool management on the 

menu bar and the following dialog is displayed. (Fig. 10-1) 

 

Fig. 10-1 

Tools commonly used in Ucancam include end mill, ball nose, bull mill and conical. New tools can be 

added and existing tools can be deleted or edited in the tool library. 

10.1.1 End Mill 

Parameters of end mill include diameter of blade (D) and height of blade (H).  

           

Fig. 10-2 (End mill)                   Fig. 10-3 (tool edit) 
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10.1.2 Ball Nose 

The parameters of ball nose include diameter of blade (D) and height of blade (H). 

         

Fig. 10-4 (Ball nose)                   Fig. 10-5 

 

10.1.3 Conical 

Conical parameters include: diameter of handle (D1), diameter of blade (D2), height of blade (H) and 

angle (A) (half angle) (Fig. 10-6) 

         

Fig. 10-6                          Fig. 10-6 

 

10.1.4 Bull Mill  

Parameters of Bull Mill include: diameter of blade, height of blade and Corner radius. It always is 

used on rough mill and area clearance. Fig 10-7 

                 

           Fig 10-7                            Fig 10-7 
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10.1.5 Tool Editing 

To add a tool 

1. Select Ball Nose from Tool Type (The selected tool is in blue). (Fig. 10-8)  

2. Then click Add. 

3. A dialog is shown for you to set the parameters of the new tool. (Fig. 10-9)  

4. Input the parameters of the tool in the dialog and click on .  

Then the newly added tool is displayed in the tool library. (Fig. 10-10) 

 

Fig. 10-8                                                                                        

   

Fig. 10-9                                  Fig. 10-10 

 

To edit a tool  

1. Select a tool in the Current Tools list. 

2. Click on Edit button and a dialog Tool Editor is displayed.  

3. Set the parameters and click on OK.  

To delete a tool 

This function is rarely used, but when you need to delete a tool from Tool Library, you should select 

a tool in Current Tools list and click on Delete button in the Tool Library dialog. Then the tool is deleted 

from the tool library. 

After introduction of the tools, we can start work now. Machining can be classified into profile 

machining, area clearance, 3D engraving, midline machining, drilling, insert and inlay machining, prism 

machining, intelligent machining, embossing machining, image dot machining, image relief machining, etc 
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10.2 Profile Machining 

Profile machining can be classified into On, Outside and Inside according to relationships between 

the tool center axis and the drawing.  

On: The tool center axis is along the original drawing.  

Outside: Cut along the outer contour of the drawing. 

Inside: Cut along the inner contour of the drawing. 

10.2.1 Parameters In Profile Machining 

Click the icon  on the Tool Path Bar or select ToolPath->Profile machining on the menu bar. 

The Profile machining dialog is displayed. (Fig.10-11) you can set machining parameters in the dialog.  

 

Fig. 10-11 

 

Parameters 

Tool library: You can choose a tool from the drop-down list of tool library or press Tool Library 

button to choose one from tool library dialog. 

 

 

Cut position: on, outside and inside. 

Bridge: In order to prevent the machined object from moving which may cause objects to be 

destroyed or machining errors, the machined object had better not be completely separated from the 

material before the machining is finished. After machining, the object can be separated from the material by 

hand. (Fig.10-12) 
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Fig. 10-12                             Fig. 10-13 

Plunge: There are 3 ways to plunge. (Fig. 10-13) 

1. Ramp 

Ramp is to plunge in a certain angle. Set the value in the dialog, and then press OK. The tool goes 

into the material not in Z axis direction but in slanting direction so that the tool will not be destroyed or 

broken because of the force during entering material. This also ensures that no mark or scar is left on the 

surface of the material. If check the “ramp up””, the tool will retract in slanting direction to ensure the 

seperation between the part and stock , even if the stock is deforming. 

 

2. Pecking plunge 

When using Pecking plunge, the tool goes into a certain depth into the material, and then goes up to 

a certain height, and repeat this process when cutting the material. Pecking plunge prevents the tool 

breaks especially when cutting hard materials. 
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3. Lead in / out 

When using Lead in / out, the tool first goes into a certain depth outside of the material, and then cuts 

into the side of the material. 

 

REMARK: Bridge and Plunge can not be activated at the same time. 

Total depth: is the total depth the tool goes into the material during machining. 

Sequence: is to machine in the shortest tool path, thus saving the machining time. (Near First: the 

nearest object to the tool will be machined first. X/Y First: machine objects along X/Y axis direction first. ) 

Multi layer: When the depth of the material is bigger than the tool height or when the material is of 

high rigidity (such as metal), the machining is done layer by layer on the material. 

Depth first: machine next object after finishing machine all the layers of one object. 

Cut direction: is the direction of the tool path, including default direction, clockwise and 

anti-clockwise. When choosing cutting direction, the material should be taken into consideration so that the 

surface of the material after being machined is smooth. Clockwise machining is fit for cutting materials of 

high density, such as Acryl (organic glass), brass, etc; anti-clockwise machining is fit for cutting materials of 

low density such as PVC board, two-color board, etc. Besides, you can also change the cut direction by 

clicking Modify->Direction on the menu bar (see Fig. 10-14). Then you can see the current cut direction. 

Click on the tool path, and a dialog is shown. Click on OK or press the Enter key on the keyboard to 

change the cut direction. (Fig. 10-16) Click the right mouse button if you do not need to preview the tool 

path. 
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Fig. 10-14                                 Fig. 10-15 

 

Fig. 10-16 

 

10.2.2 Example 

Now we are going to introduce profile machining through an example.  

1 Open a new file, and draw a circle in the drawing window. (Fig. 10-17) 

 

Fig. 10-17 

2 Select the circle, and click on the shortcut icon  on Tool Path Bar or click Tool path->Profile 

machining on the menu bar. Then the dialog shown in Fig. 10-11 is displayed. 

3 Select an end mill with a diameter of 10 and height of blade of 22, and set the value of total depth at 

10mm and choose clockwise cut direction. Then the effect is shown in Fig. 10-18. 
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Fig. 10-18 

REMARK: In profile machining, you should choose end mill or conical but not ball nose because ball 

nose is not fit for profile machining. 

 

10.3 Area Clearance 

Area clearance is to mill an area in the material. There are two types of milling: raster and offset. For 

example, we are to mill the rectangle in Fig. 10-19. 

 

Fig. 10-19 

1 Select the rectangle, then click on the shortcut icon  on Tool Path Bar or click Tool 

path->Area Clearance on the menu bar. Then the Area Clearance dialog is displayed. 

 

Fig. 10-20 
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2 Input the parameters in the dialog. 

Tool Library: is for selecting a tool. You can also select a tool in the drag down list. 

Machining strategies: is to select raster or offset area clearance. (When choosing raster, you can 

adjust the angle. when choosing Offset, you can choose inside to out according your need), specially for 

offset strategy, the transition between the loop is tangent continue arc , and the sharp angle in loop is also 

transited by arc,  therefor this strategy is fit for high speed machine. 

Machining parameters: total depth, side allowance, overlap ratio and contour allowance. 

Overlap ratio: is the ratio of the width of the tool bottom blade to the width of the last tool path. 

The reason why we need to set overlap ratio is that we need to take the width of the tool into 

consideration during machining. If the overlap ratio is too low, then some parts of the material will not be 

machined; if we keep the space between tool paths as close as possible, then the surface of the material 

after machining will be smooth. However, if the overlap ratio is too high, then the machining efficiency will 

be reduced.  

Next we are to introduce overlap ratio further through an example. 

Fig. 10-21 is the effect with the overlapping rate of 0, and the shadowing area in Fig. 10-22 is the 

overlapped part of the tool.  

        

Fig. 10-21                 Fig. 10-22 

Note: Ball nose tool should not be used in area clearance. Fig. 10-23 shows the result if ball nose tool 

is used in area clearance or milling. (The area in black is the part which is not machined.) 

 

 
Fig. 10-23 

 

Side allowance: is the area outside the tool path. Precision cutting can be achieved through setting 

side allowance. 

Mill contour: This is to make the surface of the material smooth after being machined. 
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Multi layer: When the depth of the material is bigger than the tool height or when the material is of 

high rigidity (such as metal), the machining is done layer by layer on the material. 

Adopt: you can set the depth per layer. 

Depth first: Machine next object after finishing machine all the layer of one object. 

Sequence: is to machine in the shortest tool path, thus saving the machining time. (Near First: the 

nearest object to the tool will be machined first. X/Y First: machine objects along X/Y axis direction first. ) 

Ramp: When we do area clearance, we usually use mill cutters, and mill cutters are too fragile to cut 

if we use it to cut into the material at right angle. With ramp function, the cutter breaks can be well 

prevented because the tool goes into the material in a certain angle. 

  

 

3 If we choose the end mill with a diameter of 20 and height of 10, set the angle at 0, the total depth 

at 2mm, overlap ratio of 50%, clockwise machining, then the effect is shown in Fig. 10-24. If we 

choose offset, the effect is shown in Fig. 10-25. 

   

Fig. 10-24                               Fig. 10-25 

 

10.4 3D Engraving 

3D engraving is to make the material surface smooth and to ensure the definition, precision and third 

dimension effect of the machined object. It is mainly used in seal engraving and engraving of characters 

with special effects. 

3D engraving includes top and bottom engraving, and the difference between them is the size of the 

machining area.  

Next we are going to see an example. 

1 Input text “UCA” and draw a rectangle around it in the drawing window. (Fig. 10-26) 
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Fig. 10-26 

2 Select the text and the rectangle, and then click on the shortcut icon  on Tool Path Bar or 

click Tool path->3D engraving on the menu bar, then the 3D Engraving dialog is displayed. (Fig. 

10-27) if you input parameter of Min upcast distance, times of engraving can be reduced. 

 

Fig. 10-27 

 

3 Select a conical tool in the tool library with a diameter of 0.2, height of 10, angle of 30 degrees, and 

select Top in Machining parameters with the total depth of 5mm, overlap ratio of 60%, clockwise 

engraving, and then the effect is shown in Fig. 10-28. 

    

Fig. 10-28a                               Fig. 10-28b 

4 If we choose bottom engraving and set the other parameters the same as above, then the effect is 

shown in Fig. 10-29. 
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Fig. 10-29a                          Fig. 10-29b 

REMARK: You should choose a proper tool in 3D engraving. If the diameter and angle of the tool are 

too large, then the tool can not go into some tool paths, resulting in imperfect effect. 

10.5 Midline Machining  

Midline machining is to machine along the middle axis of the drawing, and there are three types of 

midline machining: 2D machining, 3D engraving and 3D cone. The cut depth in 2D machining is fixed, and 

the material is cut along its midline and during 3D engraving the cut depth is automatically adjusted 

according to the shape of the object and the tool used. During 3D cone engraving, the cut depth is also 

automatically adjusted according to the shape of the object and the tool. 

Reverse machining is to machine along the original tool path in the reverse direction again after 

first-time machining in order to make the surface of the material smooth. 

Sequence:  is to machine in the shortest tool path, thus saving the machining time. (Near First: the 

nearest object to the tool will be machined first. X/Y First: machine objects along X/Y axis direction first. ) 

 

For example, machine the two letters “OP”. 

1 Input the two letters in the drawing window. 

2 Select the two letters and click on the shortcut icon  in Tool Path Bar or click Tool 

path->Midline machining in the menu bar, then a dialog is displayed. (Fig. 10-30) if you input 

Parameter of Min midline length, the branch of midline can be under control. 

 

Fig. 10-30 
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3 Select a conical tool with a diameter of 0.3, height of 10 and angle of 45 degrees, total depth of 6, 

and select reverse machining, 3D. Then the effect is shown in Fig. 10-31. 

 

Fig. 10-31 

10.6 Simple Drilling 

Before drilling, you set the Total depth, point space and machine type parameters. Set the parameter 

of point space can control the space between two points. Three Drill Position: on points, on curves, on 

center of object. 

E.g.1: to drill the shape shown in Fig. 10-32. 

 

Fig. 10-32 

1 Select the object, then click on the shortcut icon  in Tool Path Bar or click Tool 

path->Simple drilling in the menu bar. Then the Simple Drilling dialog in Fig. 10-33 is displayed. 

 

Fig. 10-33 

2 Select an end mill tool with diameter of 22 and height of 10, set the total depth at 5, and select on 

curves, then the effect is shown in Fig. 10-34. 
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Fig. 10-34 

E.g.2:  to drill points 

1 Draw a point and duplicate it. (Fig. 10-35) 

 

Fig. 10-35 

2 Select all the points, and click on the shortcut icon  or click Tool path->Simple drilling in the 

menu bar. Then a dialog is shown. (Fig. 10-3) Select an end mill tool with a diameter of 3 and height 

of 12, set the total depth at 10, and pick up Points. The result is shown in Fig. 10-36. 

 

Fig. 10-36 

10.7 Region Drilling 

Region drilling is to drill in the inner region of the object. 

Now we are to drill the region in Fig. 10-37. 
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Fig. 10-37 

1 Select the object, and click Tool path->Region drilling in the menu bar. Then the Region drilling 

dialog in F10-38 is displayed. 

 

Fig. 10-38 

Horizontal point space: is the distance between two points in the horizontal direction 

Vertical point space: is the distance between two points in the vertical direction 

Interlaced arrange: is interlaced arrangement of the points 

2 Select an end mill tool with a diameter of 22, weight of 10, total depth of 6, horizontal point space 

and vertical point space at 44 respectively, and compare the different results when selecting 

interlaced arrangement and when interlaced arrangement is not selected. (Fig. 10-39) 

 

Fig. 10-39 (When interlaced arrangement is chosen) 
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Fig. 10-39 (When interlaced arrangement is not chosen) 

10.8 Insert And Inlay 

Inserted and inlayed moulds are made by profile machining and area clearance.  

Now we take the letter “R” as an example to introduce this function. 

 

Fig. 10-40 

Unilateral clearance is the distance between the inlayed mould and the inserted mould, and the 

value should be relatively larger when materials of high density are machined. However, it should be noted 

that too large value of interspacing may result in looseness. This parameter is given in both the dialog of 

Inlay and Insert, and you need only input the value in one of the dialog. 

The following is the step. 

1 Select the character “R”, and then click on the shortcut icon  in Tool Path Bar or click Tool 

path->Insert and Inlay->Insert Machining in the menu bar. Then the dialog in Fig. 10-41 is 

displayed. 

 

Fig. 10-41 
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2 Select an end mill tool with a diameter of 3.175, height of 10, total depth of 10, interspaces of 0.3, 

anticlockwise, and the result is shown in Fig. 10-42. 

 

Fig. 10-42 

3 Select the letter, and click on the shortcut icon  or click Tool path->Insert and Inlay->Inlay 

Machining, and then the following dialog is displayed. (Fig. 10-43) 

   

Fig. 10-43                           Fig. 10-44 

4 Select an end mill tool with a diameter of 3.175, height of 10, total depth of 6, interspace of 0.3, 

anticlockwise, overlap ratio of 50, and the result is shown in Fig. 10-44. 

 

10.9 Prism Machining  

Features of prism machining in Ucancam include: 

Multilayer engraving: Objects are machined layer by layer. In this way, material is saved and 

machining speed is improved, especially fit for machining artworks and characters with prisms. 

Easy operation: Prism machining is very easy to use. Users need only draw the contours of 

characters with special effects, and input or adjust parameters. Then the tool path is formed. 

High efficiency: The tool path is formed quickly, and if multi-layer machining is chosen, high speed 

and efficiency can be achieved. 

Angle type: There are two kinds—rounded angle and cusp angle machining. If rounded angle 

machining is chosen, then the area between two bordered sides is rounded conical surface. 

Next we are going to apply prism machining to the object in Fig. 10-45. 
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Fig. 10-45                          Fig. 10-46 

1 Select the object, then click on the shortcut icon  in Tool Path Bar or click Tool 

path->Prism machining in the menu bar. Then the Prism machining dialog in Fig. 10-46 is 

displayed. 

2 Set the parameters in the dialog. 

Tool: This Prism machining effect is only gotten by using the conical tool. Thus, only conical tools are 

provided in the tool library. 

Parameters: You can set the material thickness and machining depth in this section. 

Angle type: includes rounded and cusp angles. 

Preview window: Prism section created is previewed in this window. 

Refresh: if the Prism section created did not show in preview window ,press refresh button. 

Prompt: It automatically prompts you whether you have chosen a proper tool, and also lets you know 

if the cutting depth is right or not. 

The system automatically tells users whether the tools or defined depth of each layer is fit for 

machining. 

3 Select a conical tool with a diameter of 0.3, height of 10, angle of 45 degrees, material thickness of 

10, machining depth of 39.19, layer depth of 10mm, anticlockwise machining, and the effect is shown 

in Fig. 10-47. Machining depth, layer and angle vary according to the tools selected. 

 

 

Fig. 10-47 

10.10 Intelligent Machining 

Efficiency in milling can be greatly improved when applying intelligent machining. Two tools can be 
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chosen at the same time, and the tool with larger diameter will be chosen for milling for the first time, then 

the tool with smaller diameter will be used in milling for the second time so that the smaller areas which are 

not milled in the first round of milling by the larger tool can be milled. By using the tool with larger diameters, 

the machining speed is greatly improved, and by using the tool with smaller diameters, accurate machining 

is achieved. 

Take the object in Fig. 10-48 for example. 

 

Fig. 10-48 

1 Select the object, and then click on the shortcut icon  in Tool Path Bar or click Tool path-> 

Intelligent machining in the menu bar. Then the Intelligent machine dialog is displayed (F10-49). 

 

Fig. 10-49 

2 Set the parameters in Fig. 10-49. 

3 Select two end mill tools with diameter of 3.175 and 22 respectively, total depth of 3mm, overlap of 

90%, anticlockwise. Then the effect is shown in Fig. 10-50. 

 

Fig. 10-50 
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The area with dense lines is the tool path of the smaller tool with a diameter of 3.175, and the other 

area is the tool path of the tool with a diameter of 22. 

10.11 Embossing Machining 

Embossing machining is mainly used in making rounded characters or shapes.  

There are two types in embossing machining: intaglio machining. The operation of embossing 

machining is quite easy, and it is widely used in such fields as embossment sign boards, badge, furniture, 

metallic moulds, printing, etc. 

Take the object in Fig. 10-51 as an example. 

 

Fig. 10-51 

1. Select the object, and click on the shortcut icon  in Tool Path Bar or click Tool 

path->Embossing machining in the menu bar. Then the dialog in Fig. 10-52 is displayed. 

 

Fig. 10-52 

2. Set the parameters in the Embossing machining dialog. 

Parameters 

Border: is the distance between the border of the contour and the tool path 

Height: is the total machining depth 

Width: is the width of the tool path 

Top angle: is the angle formed by the vertical direction and the tool when it is entering the material 

Bot angle: is the angle formed by the horizontal direction and the tool when it is entering the material 

Machining type: includes female and male machining. 

3 Select a ball nose tool with a diameter of 6, height of 12, border of 0, machining height of 6, width of 

the default value 14.762, top angle of 0, bot angle of 0, overlap of 80%, anticlockwise, then the effect 
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is shown in Fig. 10-53. 

   

Fig. 10-53                       Fig. 10-54 

Fig. 10-54 is 3D view of the tool path. 

 

10.12 Image AM/FM Machining  

Image AM/FM machining is to engrave the object after the image is converted into grayscale image.  

AM machining is to make the distance between the dots the same while the depth of the dots are 

different. 

FM machining is to make the depth of the dots the same while the distance between the dots is 

different. 

   

Fig. 10-55                            Fig. 10-56 

   

    Fig. 10-57                                  Fig. 10-58 

Horizontal point space: is the distance between two points in the horizontal direction 

Vertical point space: is the distance between two points in the vertical direction 
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Min brightness depth and Max brightness depth: is the depth tool goes in to material during 

machine. 

Mode: choose different mode for different picture.  

Frequency: is used for common picture processed by Ucamcan. 

Black white bitmap: is used for the Black white bitmap processed by other software. 

Frequency Method: 

Dither: is to make the surface of processed image seems smoother. 

Diffuse: is to highlight the details 

10.13 Image Relief Machining 

Image relief machining is to engrave the object after the image is converted into grayscale image. 

The machining is based on brightness level. 

Min brightness depth and max brightness depth are the depth by which the tool goes into the material. 

Horizontal/vertical machining is the direction of the tool path. 

Take the image in Fig. 10-59 as an example. 

1 Import a file in BMP format. 

 

Fig. 10-59 

2 Select the image, and click on the shortcut icon  in Tool Path Bar or click Tool path->Image 

relief machining in the menu bar. Then the dialog in Fig. 10-60 is displayed.  

 

Fig. 10-60 

3 Select a conical tool with a diameter of 0.2, blade height of 10, blade angle of 10, min brightness 

depth of 2, max brightness depth of 0.3, overlap of 50%, and choose horizontal machining. Then the 

3D view of the effect is shown in Fig. 10-61. 
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Fig. 10-61 

10.14 ToolPath Sequence 

Tool path sequence can be adjusted so as to improve machining process and machining quality in 

case the default tool path sequence is not what you want. 

1 Select a tool path, and click Tool path->Tool path sequence in the menu bar.  

2 Then the tool path is marked by numbers. (Fig. 10-62) 

 

Fig. 10-62 

3 Then click a sequence number to change the sequence of tool path. Or you can set the specific 

sequence number of a tool path unit by clicking the right mouse button on the original sequence 

number. The context menu displayed is shown in Fig. 10-63.  

4 After setting the sequence number in the menu, click the right mouse button again, and a dialog is 

shown. (Fig. 10-64)  

5 Click on Yes to save the new tool path sequence, or click on No to preserve the original tool path 

sequence. Fig. 10-65 is the new tool path. 

           

            Fig. 10-63                          Fig. 10-64 
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Fig. 10-65 

10.15 ToolPath Edit 

We can change the shape of the tool path by Tool path edit function. We can add, delete or move 

nodes of the tool path, or set the starting point. We can also reverse tool path direction. Other functions 

include bridge, arc fit, and feed.  

Click Toolpath -> Toolpath edit on the menu bar, and then a dialog is displayed. 

 

 

Fig 10-66 

Functions available in Tool path edit include: 

Pass:  You can select different parts of the tool path by adjusting serial number. 

Node:  You can select different nodes of the tool path by changing serial number. 

Set start Pt: You can set any point as the starting point of the tool path. 

Reverse: is to reverse the direction of the tool path. 

Show All Toolpath: Check it, and you can see all tool paths.  

Show Tool: The tool is displayed after you check it. 

Move point: You can move a node to a new position or change the shape of the tool path by 

changing the coordinates of the tool path. 
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Fig 10-67                      Fig10-68 

Add point: You can add nodes in a certain position of the tool path. A dialog is displayed after 

pressing “Add Point”. 

Del point: You can delete any node on the tool path by pressing “Del point”. 

Del section: You can delete a selected tool path section. First select the tool path, and then press 

“Del section”. 

Del Pass:  First select the tool path section that you want to delete, and then press “Del Pass”. 

         

Fig10-69                           Fig 10-70 

Bridge: To prevent cutter from being destroyed or broken because of material move when job is to be 

finished, you can use Bridge to make the cut object not completed separated from the material. After 

finishing the job, you can manually take the finished product apart from the material. 

Feed: You can set spindle Rate, Tool Feed, Fast speed and Plunge speed in this dialog. 

Arc Fit: When it comes to tool path calculation, arcs are better than Bezier curves. By this function, a 

tool path is automatically changed to an arc, thus machining efficiency is greatly improved. 

 

10.16 ToolPath Transform 

With this function, you can change the size of the tool path, change the tool path position, and rotate 

the tool path. 

1 Scale 
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Fig10-71 

You can scale the tool path by clicking Toolpath -> Toolpath Transform on the menu bar. When a 

dialog is displayed, set the values in it, and then the tool path size is changed. After choosing base point, 

checking change and setting scale of X, Y, Z, then press ok 

2 Move 

 

Fig 10-72  

You can move the tool path by clicking Toolpath -> Toolpath Transform on the menu bar. Set the 

value in the dialog, and then the tool path position is changed. 

3 Rotate 

 

Fig10-73  

You can also rotate the tool path by clicking Toolpath -> Toolpath Transform on the menu bar. 

10.17 Post Set 

There are many type of CNC systems in the worldwide. The definition for G direction and M direction 

in the different CNC systems are not quite similar, so that the requirement for command and format in NC 
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program are also different. Therefore, GCode of toolpath must be processed to adapt to special 

requirement of every machine and it’s control system. This process is called “Post set” in Ucancam 

software.  

 

Ucancam provided procedures for processor——Post Set so that the toolpath in V9 can be changed 

to CN code. Select Toolpath->Post Set, Post Set dialog is shown. you can add machine by click Add 

Machine button or delete machine by click Del Current Machine button.The parameters of Post Processor 

file include Head of programme, Tail of programme, ToolChange, Units, Format etc, these file are saved in 

the post sub-directory in the installing directory. 

After setting parameters click OK to save them. The subsequent Toolpath will be ouput according to 

the post processor file. 

10.18 ToolPath Output 

After the tool path is created, you can save it. Various file formats are provided by Ucancam post 

processor file. 

For example, we apply area clearance and contour cutting to the object in Fig. 10-74. 

 

Fig. 10-74 

In tool path module, select the object and apply area clearance and profile machining to it. Then the 

effect is shown in Fig. 10-75. 

app:ds:processor
app:ds:subsequent
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Fig 10-75 

REMARK: When creating the tool path of several objects, it is better to hide the already-formed tool 

path in order to make the operation easier. 

Select the tool path to be saved or click on the shortcut icon  on Toolpath Bar or click Tool 

path->Tool path output in the menu bar. Then the dialog in F10-76 is displayed. 

 

Fig. 10-76 

Parameters 

Post processor file:  normally select “General CNC” is OK,  if you want output the toolpath in inch. 

Or your control system has special requirement,  you shoul modify the post processor , for example 

moidify the “UNITS <mm>” to “UNITS <inch>” in the post processor file. If you need more help, you can 

contact with us . 

Origin point: is the origin of the tool before machining is carried out.  

There are 3 ways to set origin point: 

1. Custom :You can custom the position of the origin, input the value of X, Y and Z, then save 

toolpath. 

2. Save as before: Automatic memory the previous path position, and even restart the software. 

3. Base on feature points : You can select the position of the five points(A,B,C,D,E) , The location of 

the machining area is different according to the feature points selected. Take badge making as an example. 

Fig. 4 shows the location of the machining area with the origin at (0, 0). 
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Fig10-77a                                Fig. 10-77b 

In order to make origin setting more flexible and the engraving more convenient, the function “Based 

on feature points” is available in Ucancam.  

 

Safe Z height: is the distance between the tool position and the material surface when the tool is 

traveling above the material. 

Speed-down Z height: is the distance between the material surface and the position tool beginning 

to decelerate. 

 

 

Z axis reverse: in ucancam, the downward direction of original is Z axis direction, after checking Z 

axis reverse, the saved pool path is along the opposite direction of Z axis. 

File name & Save: Click on “Browse” to select the tool path to be saved, name the file and then click 

on Save. Then the tool path is saved in the file you have named. 

Up & Down: In case several tool paths are needed when machining an object, then you need to 

arrange the order of the tool path.  

Delete: A tool path can be deleted if you do not need the tool path. 

REMARK: A tool path can be deleted only after putting a tick before it. It can also be deleted if you 

select the path in the active area first before the path turns red, and then click on Delete. 

The tool path list is displayed after pressing the right mouse button. Select one tool path, and click the 

right mouse button. Then the menu in Fig. 10-78 is displayed. You can move up or down or delete the tool 

path by choosing one of the commands in the menu. 
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Fig. 10-78 

Auto Tool Change 

Working efficiency can be improved by Auto Tool Change function. Two ways to achieve this function: 

1 Before generating toolpath, you should edit serial number of tools in the tool library. Click 

Toolpath->Tool Management on menu bar, Tool library dialog is shown, then select tool in the tool library 

and press Edit button, the dialog of End Mill Tool Editor is shown for you to edit Tool No.  

   

2 After generating toolpath, you can modify tool No. in the dialog of Toolpath output. Click 

Toolpath->Toolpath output on menu bar, Toolpath output dialog is shown, select Tool No. in the list of 

Path and press  button to modify the tool No. 

 

 

10.19 ToolPath Walk Simulation 

Machining path can be previewed though tool path walk simulation, thus avoiding trial cutting and 

reducing cost.  

1 Select the tool path to be machined. 

2 Then click on the shortcut icon  in Toolpath Bar or click Toolpath->Tool path walk 

simulation in the menu bar. Then the dialog in Fig. 10-79 is displayed. 
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Fig.10-79 

3 Adjust simulation speed and click on start to see the machining process. 

In tool path walk simulation, the green frame is the path of cutting or other engraving method, and the 

red frame is the tool path of tool lifting. You can also stop tool path walk simulation process. Click on 

Refresh if you want to renew the tool path. 

4 Click on Continue to resume simulation from where it stopped. (Fig. 10-80) 

 

Fig. 10-80 

10.20 ToolPath Shaded Simulation 

Toolpath shaded simulation is to preview cutting or engraving processin realistic render mode. 

Simulated results can be rotated or scaled in order to be viewed from different angles. 

Parameters like simulation speed, precision and stock size can be set in dialog; length, thickness, 

margin, machining rate, machining type, machining tool are all displayed in the dialog. You can also set the 

texture of stock, and Mill color, V9 paints the machined regions with the selected color.  

For example, we first apply embossing machining to the characters in Fig. 10-81. After the tool path is 

calculated, select the path, and then click Toolpath->Toolpath shaded simulation in the menu bar. Then 

the dialog bar displayed on the left of the page to set the parameters. Enter the parameters, and click on 

start to see the simulation. 
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Fig. 10-81a (object)                   Fig. 10-81b (tool path) 

   

  Fig. 10-81c  simulation(none)    Fig. 10-81d simulation(Material Color wood-20) 

 

Fig. 10-81desimulation(select color & wood-20) 

10.21 ToolPath Panel 

Tool path panel is used to separate a tool path into several smaller portions so that you can machine 

materials accurately even when the work area of your machine is not big enough. After machining, you can 

combine the portions together to form a complete one. In this way, not only machining time is reduced, but 

also efficiency is improved. 
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To apply tool path panel to a tool path 

1 Select an object. 

2 Apply a tool path calculation to the object to form a tool path. 

3 Click on the tool path. 

4 Click Toolpath->Toolpath Panel in the menu bar. 

5 A dialog Toolpath Panel is displayed. 

6 Set the parameters in the dialog, and click on OK to validate the setup. 

Then the tool path is separated into several parts. 

 

Fig. 10-82 (Dialog) 

Parameters include: 

Width: is the width of each independent tool path after applying tool path panel. 

Height: is the height of each independent tool path after applying tool path panel. 

Use Aid line: is to use the guide line as the aid line to separate a tool path. 

Refresh: is to reset the above parameters. 

REMARK: When applying Toolpath panel to a tool path, you should put the object in the drawing 

window (the grey rectangular box); otherwise, the function is invalid. 

 

Fig. 10-83 (Tool Path Panel) 

10.22 Group Toolpath 

You can group several toolpaths as one unit for machining. 

Create and select two or more tool paths, and then click on ToolPath->Group Toolpath in the menu 

bar. Then the tool paths are grouped together. 
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Fig. 10-84 

10.23 Ruled Surface  

Ruled surface is a surface is generated by curve motion. 

1 Draw a wave line which Unit length is 60 mm. Unit Height is 15mm. 

2 Copy this wave line to generate another same wave line .Fig 10-85 

 

Fig 10-85 

3 Pick these two curve, click Toolpath->Ruled Surface on menu bar Fig 10-86 

 

    

Fig 10-86                                   Fig 10-87 

4 Key in parameters in dialog and press Ok to finish operation .Fig 10-87 
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10.24 ToolPath Plunge  

This is specially for editting profile path plunge. There are three type oy plunge: Ramp, Pecking,Lead 

n/out. When you have created the profile path, you can modify the path start point and the plunge 

parameter with it.     

Select the profile toolpath, then click on ToolPath->Toolpath Plunge in the menu bar. A dialog 

Toolpath Plunge is displayed. According the type of profile path plunge, there are three type of dialog: 

Ramp dialog, Pecking dialog, Lead in/out dialog in Fig 10-88a, 10-88b, 10-88c. 

             

Fig 10-88a                Fig 10-88b             Fig 10-88c 

 you can modify the start point of profile path by click the start point, and keep the left mouse key 

down, drag the mouse to move the start point. And the same time the plunge will be modified by the 

parameter of dialog. 

The” Update” button in dialog will modify all the plunge according the parameter of dialog. 

The” OK” button in dialog will save all the modified plunge and exit the command. 

The” Cancel” button in dialog will cancel all the modified plunge and exit the command.
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 11. CASES 
Several cases are given in this chapter so that users get to know the functions and operation of 

Ucancam better. 

Case1. Profile Machining 

1 Launch Ucancam. (Fig. 11-1) 

 

Fig. 11-1 

2 Click on the shortcut icon  in Editing Mode Bar or click Draw->Symbol library command in 

the menu bar. Then the symbol library is displayed on the left of the drawing window. Drag a symbol into 

the drawing window by clicking it and holding the left mouse button. (Fig. 11-2) 

 

Fig. 11-2 

3 Select the symbol and click on the shortcut icon  or click Transform->Scale command in the 

menu bar. Then the dialog in F11-3 is displayed. Set the parameters. The result is shown in Fig. 11-4. 
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Fig. 11-3                             Fig. 11-4 

4 Next we are going to calculate the tool path, but remember that you should consider whether the 

symbol is fit for the tool path chosen. For example, you need to know the relation between the diameter of 

the tool bit and the smallest line width of the symbol. The diameter of the tool bit should be smaller than the 

smallest line width. Node editing can be employed to modify the areas that tools can’t go into. Fig. 11-5 and 

11-6 show the effect before and after node editing.  

  

Fig. 11-5                            F11-6 

5 Select the symbol, and click on the shortcut icon  in Tool Path Bar or click Tool 

path->Profile Machining command in the menu bar. Then the dialog in Fig. 11-7 is displayed. Set the 

parameters. Click on OK to validate the setup and Fig. 11-8 shows the result. 

   

Fig. 11-7                           Fig. 11-8 

6 Save a tool path 

Click on the shortcut icon  on Tool Path Bar or click Tool path->Tool path output in the menu 
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bar. The dialog in Fig. 11-9 is shown. Click General CNC in the post processor File, “Point A” in “Base on 

feature points” list, and click on “Browse” to select a location to save the file. Name the file as 1.nc, click on 

Save, and then the tool path is saved in the file named “1”. 

 

Fig. 11-9   

Case2. Area Clearance 

1 Launch Ucancam. 

2 Click on the shortcut icon  in Editing Mode Bar or click Text->Text tools command in the 

menu bar, and then the text editing menu is shown on the left of the drawing window. (Fig. 11-10) 

 

F11-10 

3 Type the letter “M” in the drawing window. (Fig. 11-11) 

 

Fig. 11-11 

4 Select the letter to edit it. (You should choose the font, set values of height, width, character space, 
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line space, character angle, and base height here.) The result is shown in Fig. 11-12. 

 

Fig. 11-12 

5 Exit text editing status, and select the letter. Then click on the shortcut icon  on Transform 

Bar or select Transform->Scale command in the menu bar, and a dialog is shown. You can change the 

size of the letter. 

6 Click on the shortcut icon  on Curve Bar or select Draw->rectangle->rectangle command in 

the menu bar to draw a rectangle around the letter. (Fig. 11-13) 

 

Fig. 11-13 

7 Press Ctrl + A or click Shift key to select the two objects one by one, then click on the shortcut icon 

 on Aligning Bar or click Align->Align center command in the menu bar . The result is shown in Fig. 

11-14. 

 

Fig. 11-14 
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8 Select the rectangular frame, and click on the shortcut icon  in Modification Bar or click 

Modify->Offset command in the menu bar. Then a dialog is shown (Fig. 11-15). Set the Offset distance at 

7, choose inner direction, and the result is shown in Fig. 11-16. 

          

Fig. 11-15                          Fig. 11-16 

9 Select the inner rectangle and repeat step 8 (set the offset direction at 2and choose inner direction). 

The result is shown in Fig. 11-17. 

 

Fig. 11-17 

10 Now we apply area clearance on the letter: select the letter, click on the shortcut icon  in 

Tool Path Bar or click Tool path->Area clearance command in the menu bar. Then the dialog is shown. 

(Fig. 11-18) Choose a conical tool with a diameter of 0.3, angle of 15, blade height of 10, choose raster 

machining strategies (0 degree), a total depth of 0.2, overlap ratio of 40, anticlockwise. The result is shown 

in F11-19. 

    

Fig. 11-18                                Fig. 11-19 
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11 Then apply area clearance on the two inner rectangles, with the parameters the same as in Step 10. 

(Fig. 11-20) 

 

Fig. 11-20 

12 Finally, cut the rectangle outside by profile machining. Select the outside rectangle, click on the 

shortcut icon  on Tool Path Bar, and then a dialog is displayed. Select an end mill of 3.175, total 

depth of 1.2 (total depth is the thickness of the material), and anticlockwise machining. The result is shown 

in F11-21. 

 

Fig. 11-21 

13. Save the path: First save the tool path of profile machining of the outer rectangle with cutter lift 

height of 10, base on feature point A, and file name of “2.nc”; then save the tool path of area clearance, 

with cutter lift height at 5 and file name of “3.nc”. 

In this way, you do not need to define the tool entry location when changing the tool so that the object 

can be output directly on the machine, thus improving machining efficiency and quality. 

 

Case3. 3D Engraving 

3.1 Top surface machining  

1 Enter Ucancam. 

2 Type the letter “M”. (Fig. 11-22) 
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Fig. 11-22 

3 Select the letter to edit it. Choose the font, character height, character width, and character space.  

4 Adjust the scale of the letter. 

5 Draw a rectangle around the letter, and choose align center. 

6 Select the rectangle and the letter, and click on the shortcut icon  in Tool Path Bar or select 

Tool path->3D engraving command in the menu bar. Then a dialog is displayed. (Fig. 11-23) 

 

Fig. 11-23 

Select a conical tool with diameter of 0.2, angle of 10, and height of 10, raster machining strategy (0 

degrees), total depth of 5, overlap ratio of 40, anticlockwise, and select “Top” in machining parameters. 

Then the result is shown in F11-24. 

 

Fig. 11-24 

7 Save the tool path: save the tool path with cutter lift height at 10, base on feature point A, and name 

the file 4.nc. 

3.2 Bottom surface machining 
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The steps in bottom surface machining are the same as top surface machining. 

Fig. 11-25 is the result of bottom surface machining. 

 

Fig. 11-25 

Case4. Midline Machining 

4.1 Midline machining in 2D 

1 Launch Ucancam. 

2 Type the letter “B”, and set the font, and the parameters of character height, width, space and line 

space. Then change the scale of the letter according to your requirement. 

3 Select the letter, and click on the shortcut icon  in Tool Path Bar or select Tool path->Midline 

machining command in the menu bar. Then the Midline machining dialog is shown. (Fig. 11-26) Select a 

conical tool with diameter of 0.2, angle of 45, height of 10, 2D, set total depth at 5, and choose Reverse 

machining and the result is shown in Fig. 11-27. 

    

Fig. 11-26                              Fig. 11-27 

4 Save the tool path: save the file with cutter lift height of 10, base on feature point A, and name as 

“file1.nc”. 

 

4.2 Midline machining in 3D 

1 Launch Ucancam  

2 Input the letter “B”, and set the font, character height, character width, line space and character 

space. Change the scale of the letter according to your requirements. 

3 Select the letter, and click on the shortcut icon  in Tool Path Bar or select Tool path->Midline 
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machining command in the menu bar. Then the dialog is displayed. (Fig. 11-28) 

 

Select a conical tool with diameter of 0.2, angle of 45 and height of 10, 3D, set total depth at 5, and 

select reverse machining. The result is shown in Fig. 11-29. 

    

Fig. 11-28                            Fig. 11-29 

4 Save the tool path: save the file with cutter lift height of 10, base on feature point A, and name of 

“file1.nc”. 

Case5. Simple Drilling 

1 Launch Ucancam. 

2 Draw an ellipse and a regular polygon. (Fig. 11-30) 

 

Fig. 11-30 

3 Select the graph, and click on the shortcut icon  on Tool Path Bar or select Tool 

path->Simple drilling in the menu bar and the simple drilling dialog is shown. (Fig. 11-31) 

Select an end mill tool with diameter of 22, height of 10, set total depth at 5, point space at 44, choose 

on curves, and the result is shown in Fig. 11-32. 
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Fig. 11-31                            Fig. 11-32 

4 Save the tool path: Save the file with cutter lift height of 10, base on feature point A, and name of 

“7.nc”. 

Case6. Insert And Inlay 

1Launch Ucancam. 

2 Choose a symbol from the Symbol Library, and adjust the sizes of it if necessary. (Fig. 11-33) 

 

Fig. 11-33 

3 Ungroup the graph, and select its outer contour. (Fig. 11-34) Click on the shortcut icon  on 

Tool Path Bar or select Tool path->Insert and Inlay->Insert machining in the menu bar and the dialog in 

Fig. 11-35 is shown. 

    

Fig. 11-34                           Fig. 11-35 
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4 Select an end mill tool with a diameter of 3.175 and height of 10, choose anticlockwise machining, 

set total depth at 10, interspace at 0.3, and the result is shown .(Fig. 11-36) 

 

Fig. 11-36 

5 Next we are going to make intaglio mould. Click on the shortcut icon  on Tool Path Bar or 

select Tool path->Insert and inlay->Inlay command in the menu bar. The Inlay machining dialog is shown 

in Fig. 11-37. Choose a tool with diameter of 3.175 and height of 10, anticlockwise machining, total depth of 

10, interspace at 0, overlap ratio of 80%, area clearance, and the result is intaglio. (Fig. 11-38) 

        

F11-37                                F11-38 

6 Hide the path and select the whole object. Click on the shortcut icon  on Tool Path Bar or 

select Tool path->Area clearance command in the menu bar and the Area clearance dialog is shown in 

Fig. 11-39. Select a tool with diameter of 0.2, angle of 15 degrees, height of 10, raster machining, total 

depth of 2, overlap ratio of 35, anticlockwise. The result is shown in Fig. 11-40. 
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Fig. 11-39                             Fig. 11-40 

7 Save the tool path 

Save the insert tool path file with a file named file1.nc, base on point A, cutter lift height of 10, and 

save the intaglio tool path with a file named file2.nc, not to select the feature point, cutter lift height of 10, 

and save area clearance tool path with file named file3.nc, not to select the feature point and cutter lift 

height of 10. 

 

Case7. Prism Machining 

1 Launch Ucancam. 

2 Type the letter “W”, and adjust its size if necessary. (Fig. 11-41) 

 

F11-41 

3 Select the letter, and click on the shortcut icon  in Tool Path Bar or select Tool path->Prism 

machining in the menu bar. Then the Prism dialog is shown. (Fig. 11-42) 
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Fig. 11-42 

Select a conical tool with a diameter of 0.2, height of 10 and angle of 45, material thickness of 20, first 

cut-in depth of 10mm, rounded angle, anticlockwise machining, and the result is shown in Fig. 11-43. 

 

Fig. 11-43 

4 Hide the tool path, and select the letter to cut the contour. Click on the shortcut icon  in Tool 

Path Bar, and the profile machining dialog is shown. (Fig. 11-44) Select a tool with a diameter of 3.175, 

height of 10; choose outside cut position, total depth of 20, anticlockwise. Click on OK, and the result is 

shown in Fig. 11-45. 

     

Fig. 11-44                                    Fig. 11-45 

5 Save the tool path: save the prism machining tool path with the file named file1.nc, base on feature 

point A, cutter lift height of 10, and save the tool path of profile machining with file named file2.nc, not to 

select the feature point and cutter lift height of 10. 
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Case8. Intelligent Machining 

1. Launch Ucancam. 

2. Select a symbol from the Symbol library, and adjust its size if necessary. (Fig. 11-46) 

 

Fig. 11-46 

3 Select the symbol, and click on the shortcut icon  on Modification Bar or select Modify-> 

Array duplication command in the menu bar. Then the Array Duplication dialog is displayed. (Fig. 11-47) 

 

Fig. 11-47 

Select Rectangular duplication, and set row space and column space at 150 and 300 respectively, 

rows at 2, column at 2, and then click on OK to end the setup. The result is shown in Fig. 11-48. 

 

Fig. 11-48 

4 Horizontally mirror the symbol in the upper left corner, horizontally mirror and then vertically mirror 

the symbol in the upper right corner, and vertically mirror the symbol in the lower right corner. The result is 
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shown in Fig. 11-49. 

 

Fig. 11-49 

5 Select two more symbols from the Symbol library, and change the size of the symbol to make X 

value into 100. Align and group the symbols, and the result is shown in Fig. 11-50. 

 

Fig. 11-50 

6 Select another symbol from the Symbol library, and change the size of the symbol to make Y axis 

value into 200. The result is shown in Fig. 11-51. 

 

Fig. 11-51 

7 Press Ctrl + A key in the keyboard to select all the graphs, align the center of the graphs, and the 

result is shown in Fig. 11-52. 
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Fig. 11-52 

8 Add a box around the symbol. (Fig. 11-53) 

 

Fig. 11-53 

9 Select all the symbols, and click on the shortcut icon  on Tool Path Bar or select Tool 

path->Intelligent machining command in the menu bar. Then the Intelligent machine dialog is displayed. 

(Fig. 11-54) 

 

 

Fig. 11-54 

10 Select two end mill tools with diameter of 3.175 and 22 respectively, choose machining depth of 

3mm, overlap ratio of 60%, and choose anticlockwise. The result is shown in Fig. 11-55. 
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Fig. 11-55 

11 Select the outer box, and apply profile machining to it. Select an end mill tool with a diameter of 

3.175, height of 22, outside machining, total depth of 10, anticlockwise machining. Click on OK to get the 

result. (Fig. 11-56) 

 

Fig. 11-56 

12 Save the path: save the profile machining path with file named of file1.nc, base on feature point A, 

cutter lift height of 10, and save the intelligent tool path with the file named file2.nc, not to pick the feature 

point, and cutter lift height of 10. 

Case9. Embossing Machining 

1 Launch Ucancam. 

2 Import an object. (Fig. 11-57) 

 

Fig. 11-57 
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3 Click on the shortcut icon  on Tool Path Bar or click Tool path->Embossing machining 

command in the menu bar. Then the Embossing machining dialog is displayed. (Fig. 11-58) 

 

Fig. 11-58 

4 Select a ball nose tool with a diameter of 2 and height of 12, and set the value of border at 2, height 

at 8, width at 19.774, top and bottom angles at 0 respectively, overlap ratio at 80%, and choose 

anticlockwise machining. The result is shown in Fig. 11-59. 

 

Fig. 11-59 

5 Hide the tool path, and select the graph for area clearance. Select an end mill tool with a diameter of 

3.175 and height of 10, total depth of 8, overlap ratio of 80%, and choose anticlockwise machining. The 

result is shown in Fig. 11-60. 

 

Fig. 11-60 

6 Save the tool path: save the profile machining tool path with the file named file1.nc, base on feature 

point A, and cutter lift height of 10; save the area clearance tool path with file named file2.nc, not to select 
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the feature point, and cutter lift height of 10; save the embossing machining tool path with file named 

file3.nc, not to pick the feature point, and with cutter lift height of 10. 

 

Case10. Image FM/AM Machining 

1 Launch Ucancam. 

2 Click on the shortcut icon  on Standard Bar or click File->Import command in the menu bar 

to import an image. The Import file dialog is shown. (Fig. 11-61) 

 
Fig. 11-61 

3 Select an image in BMP format and open it. Adjust the size of the image to set X and Y both at 100, 

then the result is shown in Fig. 11-62. 

 

Fig. 11-62 

4 Select the graph, and click on the shortcut icon  in Tool Path Bar or click Tool path->Image 

AM machining command in the menu bar. Then the Image dot machining dialog is shown. (Fig. 11-63) 

Select a conical tool with a diameter of 0.3, angle of 15 degrees and height of 10, and set the horizontal 

and vertical space at 1 respectively, min brightness of 0.1, max brightness of 1.2, then the result is shown 

in Fig. 11-64.  
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Fig. 11-63                                  Fig. 11-64 

5 Click View->3D View in the menu bar and then click on the right mouse button to select ISO view 

from the context menu. (See Fig. 11-65) 

 

Fig. 11-65 

6 Save the path: save the tool path with cutter lift height of 3, base on feature point A. 

Case11. Image Relief Machining 

1 Launch Ucancam. 

2 Import an image and change the size to make X value into 100. The result is shown in Fig. 11-66. 

 

Fig. 11-66 

3 Select the image, and click on the shortcut icon  in Tool Path Bar or select Tool 

path->Image relief machining command in the menu bar. Then the Image relief machining dialog is 

displayed. (Fig. 11-67) 
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Fig. 11-67 

Select a ball nose tool with a diameter of 2 and height of 12, choose min brightness of 2.5, max 

brightness of 0.1, overlap ratio of 80%, horizontal machining, and the result is shown in Fig. 11-68. 

 

 

Fig. 11-68 

4 Click View->3D View in the menu bar, and then click on the right mouse button and select ISO View 

from the menu. The result is shown in Fig. 11-69. 

 

Fig. 11-69 

5 Save the tool path: save the tool path with cutter lift height of 5, base on feature point A.. 
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12. WAVE BOARD 
Beijing Wentai Technology corp. has successfully launched UCanCAM V9 wave board cad/cam software, 

making it easy for customers to design not only lines, curves, waves, and other designs which already exist 

on the market, but also new designs by editing or trimming. Besides, you can also trim out characters or 

graphs on waves, achieving unbelievable effect. 

The following shows the ways to make these wave designs in UCanCAM V9. 

 

12.1 Texture  

1) Draw a straight line (Fig. 1), then draw a curve. The straight line the tool path on X and Y axis, and the 

curve determines the depth of the texture, which is the Z axis tool path. The wave height is the distance 

from the top to the bottom point of the wave. (Fig. 2) 

       

Fig. 1                                    Fig. 2 

Note: It is recommended to use curve when making textures. 

2. Select the straight line, and then click wave board -> texture on the menu bar. A dialog is displayed. 

(Fig. 3)  

 
Fig. 3 

3. Select a suitable tool, and set min depth, max. depth and accuracy, and then click with left mouse button 

on Pick baseline (z axis). Then select the curve we have drawn. (Fig. 4)  
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Fig. 4 

4. Click on  to create the tool path. View the tool path in 3d view, then we get the clear effect. 

(Fig. 5) 

 

Fig. 5 

Next, we are going to make a wave board with textures.  

1．Draw two straight lines that are parallel to each other, and draw two curves that are symmetrical. (Fig. 6) 

 

Fig. 6 

2. Create tool paths for each pair of the two lines. Select one curve as baseline of one straight line, and 

select the other curve as the baseline of the other. The tool path is shown in Fig. 7.  
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Fig. 7 

3. Duplicate the tool path. (Fig. 8) 

 

Fig. 8 

 

12.2 Straight Texture  

Click on wave board -> straight texture, and then the dialog is displayed. (Fig. 9) 

 
Fig. 9 

Next we are going to explain the settings in this dialog. 

Machining settings 

Board height: the height of the board to be processed 

Board width: the width of the board to be processed 

Overlap: the proportion of the overlapped tool path to the last one 
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Path space: the space between each tool path 

Min depth: the min depth the tool goes into the board 

Accuracy: the accuracy of the texture. The accuracy is better when the setting is lower, and the time 

needed for calculating is longer. 

Note: Overlap and the path space are the same. So you need to just set one of them when creating the 

tool path. 

Baseline setting (Fig. 10) 

Height: the height of the z axis curve that is the depth of the tool going into the material.  

Height = min depth + wave height  

Width: the width of z axis curve  

 

Fig. 10 

Bamboo strip (Fig. 11)                       Straight wave (Fig. 12) 

    

Fig. 11                              Fig. 12 

 

12.3 Curvilinear texture 

Click on wave board -> curvilinear texture, and a dialog is displayed. (Fig. 13) 
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Fig. 13 

Machining settings are the same as straight texture.  

Baseline settings 

 
Fig. 14 

Sample line settings (Fig. 15) 

 
Fig. 15 

Height: the height of X axis curve. 

Width: the width of Y axis curve.  
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Fig. 16 

 

12.4 Wave 

Click on wave board -> wave, and a dialog is displayed. (Fig. 17) 

 
Fig. 17 

Wave angle: the angle of the machining path of the curve 

Fold height: the height of the wave fold 

Baseline parameters （Fig. 18） 

 
Fig. 18 

Sample line parameters （Fig. 19） 
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Fig. 19 

Machining settings are the same as curvilinear texture. （Fig. 20） 

    

Fig. 20                            Fig. 21 

12.5 Silk Texture  

Silk texture is a kind of solid wave boards.  

There are three ways to make silk textures.  

1. Middle wider: the texture start to become narrow on the two ends, the middle part is the widest. 

2. Start wilder: the texture is wildest at the beginning, and then goes lower. 

3. End wilder: the texture is wildest at the end, just the opposite of Start wilder.  

Draw some anomalistic curves and lines. (Fig. 22)  

 
Fig.22 

Select all the lines and curves, and then click wave board -> silk texture from the menu bar. A dialog is 

displayed. (Fig. 23)  
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Fig. 23 

Set the parameters in the dialog to create tool path, and then click on OK. (Fig. 24)  

     

  Fig. 24a                           Fig. 24b 

 

12.6 Texture Trimming 

Sometimes we need to make a rectangle from the tool path of the wave board (Fig. 25), at this time, we 

need to use texture trimming function. 

Click on wave board-> texture trimming on the menu bar, and a dialog is displayed. (Fig. 26)  

       

Fig. 25                                      Fig. 26 

Click on Pick a trimmed area object, and then the screen displays the main window panel. Move the mouse, 

when the rectangle becomes blue, click on the left mouse button. Then a dialog is displayed. (Fig. 27) 
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Fig. 27 

Click on OK to finish the operation, then the following result is shown. (Fig. 28) 

 

Fig. 28 

After creating the tool path, click on tool path-> toolpath output on the menu bar to save it. Then you can 

start the machining. 

Besides the above-mentioned waves, you can also create new ones by the editing, trimming, modification 

and other functions in UCanCam V9 software. 
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Ucancam Post Processor 
 

the Post Processor is a programme which converts the tool path in some standard neutral format into 

the format requried by a specific machine control system. For example the G code format supported 

wordwide by many control systems and PLT3D suported by Roland machine. 

Because the wide range of control system on the market, the majority of controls have simple 

formatting requirments. And therefore UCancam supply a configurable post  processor which can be used 

by customers or agents to create a post proceesor file to support their controls.This configurable post 

proceesor use an unicode ASCII configration file to specify the output format required.  

An example of a configuration file is shown on the below: 

 

////////////////////////////         

FORMAT <X|X%1.3f |1.0>           

FORMAT <Y|Y%1.3f |1.0>           

FORMAT <Z|Z%1.3f |1.0>           

FORMAT <S|S%d |1>                

FORMAT <F|F%d |1>                

UNITS <MM>                       

///////   

FILE_EXTENSION <nc>              

////////////////////////////   

PROG_HEAD <G90G17G21>            

TOOLCHANGE <M06 T$TN>            

PROG_TAIL <M30>                  

 

Briefly, the entries in configuration flie fall into four main categories which can be described as below 

1. Global Statements 

These determine the file extensions, whether the output is in mm or inches. 

Line numbering information and formattong for numeric fileds 

 

2. Head of Pogramme 

This section deals with line that must be output at the head of every programme.This information 

usually has the programme name, command for switching on the spindle etc.  

for example： 

PROG_HEAD <%:$DATE：$TIME> 

PROG_HEAD <G90G17G21> 

The word suffix “$” is variable. 

 

3. Tail of Pogramme 

This section deals with line that must be output at the tailof every programme. This information 

usually has the programme name, command for switching off the spindle etc, moving the tool 
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back to the home position. 

 for example : 

PROG_TAIL <M30> 

    PROG_TAIL <%> 

 

4. TOOLCHANGE 

If the machine tool is equiped with an automatic toolchanger, or user wants to allow manual tool 

changes through an output file.this statement can be used to ouput the appropriate commans. 

For example： 

TOOLCHANGE <M05> 

TOOLCHANGE <M06 T$TN> 

(TN:  current tool number) 

 

The schema of configuration file is : KEY WORD < description/value> 

First word in the line is key word that is defined by Ucancam like as UNITS. 

These in the brackets contain the description for command or values. For example : UNITS <MM>. To 

define the output is in milimeter. 

 

The key word in Ucancam include two type:the one is to deinfe the commands. 

The other is variable that is referenced in post processor file with prefix “$” 

The following is the key word for commands 

KEY WORD Specification 

FORMAT to define the formatting fornumeric fields 

PROG_HEAD head of programme 

PROG_TAIL tail of programme 

TOOLCHANGE tool change command 

G00_DEF commamd name for rapid moving 

G01_DEF commamd name for line cutting  

G02_DEF commamd name for CW arc cutting  

G03_DEF commamd name for CCW arc cutting  

G20_DEF commamd name for inch unit  

G21_DEF commamd name for mm unit 

SPN_CW commamd name for spindle CW rotation 

FILE_EXTENSION File extension name 

UNITS Unit for length 

XYZ_SEQ Sequence for XYZ 

LINE_NUM_START The start line number 

LINE_NUM_INCREMENT Line number increment 

LINE_NUM_MAXIMUM Maximum value for line number 

OMIT_SAME_GCODE Omit the same G code 

OMIT_SAME_XYZ Omit the same XYZ value 
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RAPID_MOVE_XY_Z Sequency for rapid moving 

ARC_TO_LINES  Convert arc to lines 

END_OF_LINE The string at the end of line 

The following is the key word for variable  

KEY WORD Specification 

DATE Date of create file 

TIME Time of vreate file 

FILENAME File name 

XSIZE Toolpath size for x axis 

YSIZE Toolpath size for y axis 

ZSIZE Toolpath size for z axis 

XMIN Toolpath minimum value for x axis 

YMIN Toolpath minimum value for y axis 

ZMIN Toolpath minimum value for z axis 

XMAX Toolpath maximum value for x axis 

YMAX  Toolpath maximum value for y axis 

ZMAX  Toolpath maximum value for z axis 

X_CURPOS Current x position 

Y_CURPOS Current y position 

Z_CURPOS Current z position 

LN Line number 

TN Tool number 

TOOL_DESC Tool description  

FC Feedrate for cutting  

FR Feedrate for rapid moving  

SPN_SPEED Spindle rotation speed 

SAFE_Z_POS Safe height 

FORMAT  

Output firmat for Variable in UCancam include : 

FORMAT <N|N%d > 

FORMAT <X|X%1.3f |1.0> 

FORMAT <Y|Y%1.3f |1.0> 

FORMAT <Z|Z%1.3f |1.0> 

FORMAT <S|S%d |1> 

FORMAT <F|F%d |1> 

FORMAT <I|I%1.3f |1.0> 

FORMAT <J|J%1.3f |1.0> 

FORMAT <K|K%1.3f |1.0> 

FORMAT <R|R%1.3f |1.0> 

FORMAT <A|A%1.3f |1.0> 
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The field in brackets are separated as three parts by character “|” .eg:  

FORMAT <X|X%1.3f |1.0>, the first part is Key character of Ucancam , “X” mean the current format is 

for x coordinate. Ucancam key characters of format include : N  X  Y  Z  S  F  I  J  K  R  A.  

N:  line number. 

X:  x cordinate 

Y:  y cordinate 

Z:  z cordinate 

S:  spindle rotation speed 

F:  spindle feedrate 

I:   arc  x  increment  value 

J:   arc  y  increment  value 

K:   arc  z  increment  value 

R:  arc radius 

A;  angle for rotation axis  

 

The second part is the string to print before value when output。 %1.3f  is  format  string to 

control the number of decimal  places leading zero etc.  “1”  is number that specifies minimum number 

of characters output. “3” is the precision specification value that specifies maximum number of characters 

printed for all or part of the output field 

 

5.G00_DEF、G01_DEF、G02_DEF、G03_DEF、G20_DEF、G21_DEF 

Define the command string name that  repace for ISO G Code G00 ,G01, G02, G03, G20, G21. Eg: 

G00_DEF <G172> 

 

6. Arc commad 

1）ARC_TO_LINES <1> 

Possible value: 1 or 0  

Convert the arc to lines.  

Default: 0 

 

2）the format of arc output  

FORMAT <I|I%1.3f |1.0> 

FORMAT <J|J%1.3f |1.0> 

FORMAT <K|K%1.3f |1.0> 

 

Or  

FORMAT <R|R%1.3f |1.0> 

If set the IJK format in the post processor file, the ouput for arc is in IJK format。If set the R format, 

the ouput for arc is in R format. 

Default: R format  

7.line numbering  

FORMAT <N|N%d >                      
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There are two meanings:  

(1) output the line number.if not set this statement, ucancam do not output line number.  

(2) Set the format of line number 

 

LINE_NUM_START <1>                   

Start line number 

Default: 1 

LINE_NUM_INCREMENT <1>              

Increment line number 

Default: 1 

 

8.UNITS     

Possible value: MM or INCH 

MM: All position in mm, feed in mm/min 

INCH: All position in inches, feed in inches/min 

 

9.FILE_EXTENSION  

Defines the file extension that is used for files created with toolpath output. 

10.Rotary_AXIS  

This is used only in post processor which are used to drive a machine using rotary axis. 

Possible value:  X or Y 

Either the X oy Y coordinate is mapped to rotary axis. 

 

If this staement is present , Ucancam will display the dialog which show the  

Diameter of rotary axis, the default value for diameter is assume that complete the length of toolpath 

along the axis being wrapped is the circumference of the cylinder. 

11.OMIT_SAME_GCODE    

Possible value: 1 or 0 

Omit the following same G code in output file . 

Default: 0. 

 

Eg:  G01 x010.000 Y 20.000 Z0.000 

  G01 x010.000 Y 20.000 Z-5.000 

 

if set the statement : OMIT_SAME_GCODE <1> 

the ouput  is : 

G01 x010.000 Y 20.000 Z0.000 

 x010.000 Y 20.000 Z-5.000 

 

12.OMIT_SAME_XYZ      

OMIT_SAME_XYZ <1>   

Possible value:  1 or 0. 
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Omit the folowing same xyz coordinate. 

Default: 0. 

 

Eg:  G01 x010.000 Y 20.000 Z0.000 

  G01 x010.000 Y 20.000 Z-5.000 

 

if set the statement : OMIT_SAME_XYZ <1> 

the ouput  is : 

G01 x010.000 Y 20.000 Z0.000 

G01 Z-5.000 

 

13.RAPID_MOVE_XY_Z   

Possible value: 1 or 0 

If setthe statement :  RAPID_MOVE_XY_Z <1>  , the rapid move of tool from 

 PointA(0,0,10) to point pointB(100,50,0) isseperated I n two part, firstly from pointA(0,0,10) to 

midpoint(100,50,10), second ly from midpoint(100,50,10) to pointB(100,50,0). 

14.XYZ_SEQ 

Possible value:  XYZ, XZY, YXZ, YZX, ZXY, ZYX. 

This statement specifies the sequence of point coordinate is printed out . 

15.END_OF_LINE 

  This statement specifies the character ouput at the end of line. 

  Default: none. 

16.XSIZE、YSIZE、ZSIZE  

The size of The toolpath in x axis, y axis, z axis. 

17.XMIN、YMIN、ZMIN、XMAX、YMAX、ZMAX 

The minimum and maximun value of the toolpath 

18.X_CURPOS、Y_CURPOS、Z_CURPOS 

Current tool point coordiant 

19.SPN_SPEED 

Spindle rotation speed. 

20.FC  

Tool feedrate for cutting 

21.FR  

Tool feedrate for rapid moving. 

22.SAFE_Z_POS 

Safe height. 

 

The following is example of pots processor file:  

Eg1：general CNC 

//line number 

//FORMAT <N|N%d > 

/////////////////// 



Appendix 

204 

FORMAT <X|X%1.3f > 

FORMAT <Y|Y%1.3f |1.0> 

FORMAT <Z|Z%1.3f |1.0> 

FORMAT <S|S%d |1> 

FORMAT <F|F%d |1> 

////////////////////////////// 

UNITS <MM> 

///////////////////////////////// 

FILE_EXTENSION <nc> 

///////////////////////////////// 

LINE_NUM_START <1> 

LINE_NUM_INCREMENT <1> 

///////////////////////////////// 

PROG_HEAD <G90G17G21> 

 

TOOLCHANGE <M06 T$TN> 

 

PROG_TAIL <M30> 

 

Eg2：HP_PLT3D 

 //precision  = 0.025,   1/0.025=40  

FORMAT <X|%1.0f, |40.0> 

FORMAT <Y|%1.0f, |40.0> 

FORMAT <Z|%1.0f |40.0> 

/////////////////////////////////// 

UNITS <MM> 

//convert arc into lines 

ARC_TO_LINES  <1> 

RAPID_MOVE_XY_Z  <0> 

END_OF_LINE   <;> 

/////////////////////////////////// 

FILE_EXTENSION <plt> 

////////////////////////////////// 

 PROG_HEAD <IN;> 

 PROG_HEAD <SP1> 

 

G00_DEF <PU> 

G01_DEF <PD> 

 

TOOLCHANGE <SP$TN> 

 

PROG_TAIL <SP0> 


